summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-27 00:51:26 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-27 01:05:27 +0100
commitd0b80cf50497186677d6725b1984ad7d2f9723ac (patch)
treee94aba3903af0a1f496f2182ad5feeab99e83db6 /app-emacs/elpy
parentapp-emacs/emacs-ipython-notebook: enable python 3.11 (diff)
downloadgentoo-d0b80cf50497186677d6725b1984ad7d2f9723ac.tar.gz
gentoo-d0b80cf50497186677d6725b1984ad7d2f9723ac.tar.bz2
gentoo-d0b80cf50497186677d6725b1984ad7d2f9723ac.zip
app-emacs/elpy: enable python 3.11
Closes: https://bugs.gentoo.org/896532 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/elpy')
-rw-r--r--app-emacs/elpy/elpy-1.35.0_p20220321.ebuild9
-rw-r--r--app-emacs/elpy/elpy-1.35.0_p20220627.ebuild9
2 files changed, 10 insertions, 8 deletions
diff --git a/app-emacs/elpy/elpy-1.35.0_p20220321.ebuild b/app-emacs/elpy/elpy-1.35.0_p20220321.ebuild
index dc6a90317b97..efe3533b8b1b 100644
--- a/app-emacs/elpy/elpy-1.35.0_p20220321.ebuild
+++ b/app-emacs/elpy/elpy-1.35.0_p20220321.ebuild
@@ -3,11 +3,11 @@
EAPI=8
-COMMIT=1746e7009000b7635c0ea6f1559018143aa61642
+[[ ${PV} == *_p20220321 ]] && COMMIT=1746e7009000b7635c0ea6f1559018143aa61642
DISTUTILS_SINGLE_IMPL=ON
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
NEED_EMACS=24.4
@@ -16,7 +16,7 @@ inherit distutils-r1 elisp
DESCRIPTION="Emacs Python Development Environment"
HOMEPAGE="https://github.com/jorgenschaefer/elpy/"
SRC_URI="https://github.com/jorgenschaefer/${PN}/archive/${COMMIT}.tar.gz
- -> ${P}.tar.gz"
+ -> ${P}.tar.gz"
S="${WORKDIR}"/${PN}-${COMMIT}
LICENSE="GPL-3+"
@@ -44,11 +44,12 @@ BDEPEND="
)
"
-DOCS=( CONTRIBUTING.rst README.rst )
PATCHES=(
"${FILESDIR}"/${PN}-elpy.el-yas-snippet-dirs.patch
"${FILESDIR}"/${PN}-elpy-rpc.el-elpy-rpc-pythonpath.patch
)
+
+DOCS=( CONTRIBUTING.rst README.rst )
SITEFILE="50${PN}-gentoo.el"
distutils_enable_sphinx docs --no-autodoc
diff --git a/app-emacs/elpy/elpy-1.35.0_p20220627.ebuild b/app-emacs/elpy/elpy-1.35.0_p20220627.ebuild
index be51e73e3a83..df58b81f475a 100644
--- a/app-emacs/elpy/elpy-1.35.0_p20220627.ebuild
+++ b/app-emacs/elpy/elpy-1.35.0_p20220627.ebuild
@@ -3,11 +3,11 @@
EAPI=8
-COMMIT=de31d30003c515c25ff7bfd3a361c70c298f78bb
+[[ ${PV} == *_p20220627 ]] && COMMIT=de31d30003c515c25ff7bfd3a361c70c298f78bb
DISTUTILS_SINGLE_IMPL=ON
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
NEED_EMACS=24.4
@@ -16,7 +16,7 @@ inherit distutils-r1 elisp
DESCRIPTION="Emacs Python Development Environment"
HOMEPAGE="https://github.com/jorgenschaefer/elpy/"
SRC_URI="https://github.com/jorgenschaefer/${PN}/archive/${COMMIT}.tar.gz
- -> ${P}.tar.gz"
+ -> ${P}.tar.gz"
S="${WORKDIR}"/${PN}-${COMMIT}
LICENSE="GPL-3+"
@@ -44,11 +44,12 @@ BDEPEND="
)
"
-DOCS=( CONTRIBUTING.rst README.rst )
PATCHES=(
"${FILESDIR}"/${PN}-elpy.el-yas-snippet-dirs.patch
"${FILESDIR}"/${PN}-elpy-rpc.el-elpy-rpc-pythonpath.patch
)
+
+DOCS=( CONTRIBUTING.rst README.rst )
SITEFILE="50${PN}-gentoo.el"
distutils_enable_sphinx docs --no-autodoc