summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-06 21:17:10 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-07 01:08:31 +0200
commit689ca4b0493004e87f61e7e045306799feb1e55c (patch)
treed02a33607a394c0b08002c87b2fb43f496ff3879 /app-emacs/embark
parentsys-apps/system-monitoring-center: bump to 2.17.2 (diff)
downloadgentoo-689ca4b0493004e87f61e7e045306799feb1e55c.tar.gz
gentoo-689ca4b0493004e87f61e7e045306799feb1e55c.tar.bz2
gentoo-689ca4b0493004e87f61e7e045306799feb1e55c.zip
app-emacs/embark: bump to 0.22.1_p20230630
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/embark')
-rw-r--r--app-emacs/embark/Manifest1
-rw-r--r--app-emacs/embark/embark-0.22.1_p20230630.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/embark/Manifest b/app-emacs/embark/Manifest
index e559a244a6de..9af1b8540bd1 100644
--- a/app-emacs/embark/Manifest
+++ b/app-emacs/embark/Manifest
@@ -1 +1,2 @@
DIST embark-0.21.tar.gz 102588 BLAKE2B 5a578fe25018591e4dbbe4b683ce1e8669003fdedef3c6eecdf039fdcdc7b2d5accbd95faebe369b5dac90be8beb3be7c0507190f2cac4556a25a58709aef7c9 SHA512 ab450ab17d17fa4673615d6daef9495d4e567ab612f4a732f7536427b71dffecbb0456accc7adb28cedb3f1a73709fa2e51cb01f20902dc7748755ee1ea2442c
+DIST embark-0.22.1_p20230630.tar.gz 108455 BLAKE2B d3af76c4a916942302d1588d258343134cb3bca530ea617047352fd3a5326dbe64e6dc504891ab795a89deb3500954749a80a9a2b22316f2978b70711b5cb383 SHA512 69c4b223fa205f52e90b590591968d247e03b90ae994f78f636fe7151360afab742ac31e08023ce52a9c391e1d3ba7435aa8128c3de96b1db4b1301becfa570b
diff --git a/app-emacs/embark/embark-0.22.1_p20230630.ebuild b/app-emacs/embark/embark-0.22.1_p20230630.ebuild
new file mode 100644
index 000000000000..0d2dacbae86d
--- /dev/null
+++ b/app-emacs/embark/embark-0.22.1_p20230630.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp optfeature
+
+DESCRIPTION="Conveniently act on minibuffer completions inside GNU Emacs"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oantolin/${PN}.git"
+else
+ [[ ${PV} == *_p20230630 ]] && COMMIT=f2dcfe4d797a3ab66bb603d5cf441ae1172a672d
+ SRC_URI="https://github.com/oantolin/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="avy-embark-collect.el embark-consult.el"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.texi
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "Avy integration for Embark" app-emacs/avy-embark-collect
+ optfeature "Consult integration for Embark" app-emacs/embark-consult
+}