summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/haskell-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/haskell-mode')
-rw-r--r--app-emacs/haskell-mode/Manifest2
-rw-r--r--app-emacs/haskell-mode/files/50haskell-mode-gentoo.el1
-rw-r--r--app-emacs/haskell-mode/haskell-mode-13.07.ebuild45
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.9.1.ebuild41
-rw-r--r--app-emacs/haskell-mode/metadata.xml8
5 files changed, 97 insertions, 0 deletions
diff --git a/app-emacs/haskell-mode/Manifest b/app-emacs/haskell-mode/Manifest
new file mode 100644
index 000000000000..2f5cff89dafd
--- /dev/null
+++ b/app-emacs/haskell-mode/Manifest
@@ -0,0 +1,2 @@
+DIST haskell-mode-13.07.tar.gz 131102 SHA256 7d16441f67e027a9fccbe58e3d8284489f811f4914a9e07fcc73fa9a24b38895 SHA512 e19d55a99f4d9a571c1ed0b095254e4d1b8080d9ba671461aa228cbf8aa7c7a213e19e588c0f69450a1bd4ac25793b523415a6f11bfb5dda7706dc35f7beee68 WHIRLPOOL 56be74675d47928cbb149515f796f7e45fe5238df26021510a140c1ca0613ded959b2891525350a9eb4aa39bf2a2f1e0a890e9a5cc8db35ac75c1ae37ab2761f
+DIST haskell-mode-2.9.1.tar.gz 123579 SHA256 cac350804a89d0f76fcbe8c2ad10e4b9f83d81242dbd4927b546248db9477348 SHA512 7c4cbdfd0f9e43ab3efd39c8ca7fcd941538865fe41522703175b7ca8a67276945ef7feef4207fa66aee156a028cb52bb96593867db0c777baba9f59415ee979 WHIRLPOOL bb31e6cb4e7f12c79ae4eeaf55cbed54bdb814e56c691d87da4612f884de7de018796d85442ae44f9aec323815982154b95d4555cebb7198820a639edbd03e7a
diff --git a/app-emacs/haskell-mode/files/50haskell-mode-gentoo.el b/app-emacs/haskell-mode/files/50haskell-mode-gentoo.el
new file mode 100644
index 000000000000..90e85d0a4291
--- /dev/null
+++ b/app-emacs/haskell-mode/files/50haskell-mode-gentoo.el
@@ -0,0 +1 @@
+(load "@SITELISP@/haskell-site-file" nil t)
diff --git a/app-emacs/haskell-mode/haskell-mode-13.07.ebuild b/app-emacs/haskell-mode/haskell-mode-13.07.ebuild
new file mode 100644
index 000000000000..a2027acc102c
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-13.07.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://projects.haskell.org/haskellmode-emacs/
+ http://www.haskell.org/haskellwiki/Emacs#Haskell-mode"
+SRC_URI="https://github.com/haskell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="haskell-mode.texi"
+DOCS="NEWS README.md examples/*.hs examples/init.el"
+
+src_prepare() {
+ # We install the logo in SITEETC, not in SITELISP
+ # https://github.com/haskell/haskell-mode/issues/102
+ sed -i -e "/defconst haskell-process-logo/{n;" \
+ -e "s:(.*\"\\(.*\\)\".*):\"${SITEETC}/${PN}/\\1\":}" \
+ haskell-process.el || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file haskell-site-file.el
+}
+
+src_test() {
+ # perform tests in a separate directory #504660
+ mkdir test && cp *.el Makefile test || die
+ emake -C test check
+}
+
+src_install() {
+ elisp_src_install
+ insinto "${SITEETC}/${PN}"
+ doins logo.svg
+}
diff --git a/app-emacs/haskell-mode/haskell-mode-2.9.1.ebuild b/app-emacs/haskell-mode/haskell-mode-2.9.1.ebuild
new file mode 100644
index 000000000000..3918b753066c
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-2.9.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+MY_PV=${PV//./_}
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://projects.haskell.org/haskellmode-emacs/
+ http://www.haskell.org/haskellwiki/Emacs#Haskell-mode"
+SRC_URI="https://github.com/haskell/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+DOCS="NEWS README.md *.hs examples/init.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ # We install the logo in SITEETC, not in SITELISP
+ # https://github.com/haskell/haskell-mode/issues/102
+ sed -i -e "/defconst haskell-process-logo/{n;" \
+ -e "s:(.*\"\\(.*\\)\".*):\"${SITEETC}/${PN}/\\1\":}" \
+ haskell-process.el || die
+}
+
+src_compile() {
+ elisp-make-autoload-file haskell-site-file.el || die
+ elisp-compile *.el || die
+}
+
+src_install() {
+ elisp_src_install
+ insinto "${SITEETC}/${PN}"
+ doins logo.svg
+}
diff --git a/app-emacs/haskell-mode/metadata.xml b/app-emacs/haskell-mode/metadata.xml
new file mode 100644
index 000000000000..c94cb834097f
--- /dev/null
+++ b/app-emacs/haskell-mode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="github">haskell/haskell-mode</remote-id>
+</upstream>
+</pkgmetadata>