summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-18 20:05:15 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-18 20:05:49 +0200
commita33ce22f1bea7ad557fcef3f676d00901a2e6d56 (patch)
treea41ef41acb7d61b01b0a51a9648d3704382941ed /app-emacs/matlab
parentapp-portage/gemato: Bump to 14.2 (diff)
downloadgentoo-a33ce22f1bea7ad557fcef3f676d00901a2e6d56.tar.gz
gentoo-a33ce22f1bea7ad557fcef3f676d00901a2e6d56.tar.bz2
gentoo-a33ce22f1bea7ad557fcef3f676d00901a2e6d56.zip
app-emacs/matlab: Generate autoload file.
Closes: https://bugs.gentoo.org/698006 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/matlab')
-rw-r--r--app-emacs/matlab/files/50matlab-gentoo-3.3.6.el2
-rw-r--r--app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild (renamed from app-emacs/matlab/matlab-3.3.6_pre20191010.ebuild)7
2 files changed, 8 insertions, 1 deletions
diff --git a/app-emacs/matlab/files/50matlab-gentoo-3.3.6.el b/app-emacs/matlab/files/50matlab-gentoo-3.3.6.el
new file mode 100644
index 000000000000..499ac3d66b2a
--- /dev/null
+++ b/app-emacs/matlab/files/50matlab-gentoo-3.3.6.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "matlab-load" nil t)
diff --git a/app-emacs/matlab/matlab-3.3.6_pre20191010.ebuild b/app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
index 42573b3e47ca..33487fa8e1bb 100644
--- a/app-emacs/matlab/matlab-3.3.6_pre20191010.ebuild
+++ b/app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
@@ -14,5 +14,10 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
S="${WORKDIR}/matlab-emacs-src"
-SITEFILE="50${PN}-gentoo.el"
+SITEFILE="50${PN}-gentoo-3.3.6.el"
DOCS="README.org INSTALL ChangeLog*"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file matlab-load.el
+}