summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-06-18 06:13:42 +0200
committerHans de Graaff <graaff@gentoo.org>2021-06-18 06:14:43 +0200
commitf47acd3d59c6cce674d7945e30348bc835ca9f38 (patch)
tree9618c7f32dc034bbbf17e497c2d59bf090ebeb62 /app-emacs/puppet-mode/puppet-mode-0.4.ebuild
parentapp-emacs/puppet-mode: cleanup (diff)
downloadgentoo-f47acd3d59c6cce674d7945e30348bc835ca9f38.tar.gz
gentoo-f47acd3d59c6cce674d7945e30348bc835ca9f38.tar.bz2
gentoo-f47acd3d59c6cce674d7945e30348bc835ca9f38.zip
app-emacs/puppet-mode: add 0.4
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-emacs/puppet-mode/puppet-mode-0.4.ebuild')
-rw-r--r--app-emacs/puppet-mode/puppet-mode-0.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/puppet-mode/puppet-mode-0.4.ebuild b/app-emacs/puppet-mode/puppet-mode-0.4.ebuild
new file mode 100644
index 000000000000..4f99ae64d690
--- /dev/null
+++ b/app-emacs/puppet-mode/puppet-mode-0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Puppet manifests"
+HOMEPAGE="https://github.com/voxpupuli/puppet-mode"
+SRC_URI="https://github.com/voxpupuli/puppet-mode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+
+DOCS="CHANGES.md README.md"
+SITEFILE="50${PN}-1-gentoo.el"
+
+# Tests require unpackaged ert-runner
+RESTRICT="test"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed -i -e 's/@VERSION@/'${PV}'/' puppet-mode.el || die
+}