summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-08 11:52:19 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-08 16:00:12 +0200
commitf156f4bd4540c859c44f73bf9b73ba4d6babaa91 (patch)
tree7a3055c47b8634b38bb5764abeafde750fc8838f /app-emacs/pyvenv
parentapp-emacs/mocker: new package; add version 0.5.0 (diff)
downloadgentoo-f156f4bd4540c859c44f73bf9b73ba4d6babaa91.tar.gz
gentoo-f156f4bd4540c859c44f73bf9b73ba4d6babaa91.tar.bz2
gentoo-f156f4bd4540c859c44f73bf9b73ba4d6babaa91.zip
app-emacs/pyvenv: new package; add version 1.21
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/pyvenv')
-rw-r--r--app-emacs/pyvenv/Manifest1
-rw-r--r--app-emacs/pyvenv/files/50pyvenv-gentoo.el1
-rw-r--r--app-emacs/pyvenv/metadata.xml13
-rw-r--r--app-emacs/pyvenv/pyvenv-1.21.ebuild28
4 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/pyvenv/Manifest b/app-emacs/pyvenv/Manifest
new file mode 100644
index 000000000000..9a2e91286a4d
--- /dev/null
+++ b/app-emacs/pyvenv/Manifest
@@ -0,0 +1 @@
+DIST pyvenv-1.21.tar.gz 9187 BLAKE2B 59d3eee5f0c3da44c48d6fad8fc6803e6080e54696dd5071d05a716916a2f469f0b6c812bae68eb5f1ab4a99cefae7d7128fe7a0bb2a9ccce68cdc710e02632e SHA512 5b9bf67c2882a6a4b6ff8ec2c2485a21085882c66a265f3eb3ff9650e1e7a19642acd066767c049edf61f8514799c6d24420f68a467c79498223e92cd5be8c66
diff --git a/app-emacs/pyvenv/files/50pyvenv-gentoo.el b/app-emacs/pyvenv/files/50pyvenv-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/pyvenv/files/50pyvenv-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/pyvenv/metadata.xml b/app-emacs/pyvenv/metadata.xml
new file mode 100644
index 000000000000..b763ca453b21
--- /dev/null
+++ b/app-emacs/pyvenv/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/jorgenschaefer/pyvenv/issues/</bugs-to>
+ <remote-id type="github">jorgenschaefer/pyvenv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/pyvenv/pyvenv-1.21.ebuild b/app-emacs/pyvenv/pyvenv-1.21.ebuild
new file mode 100644
index 000000000000..c16f57b1102b
--- /dev/null
+++ b/app-emacs/pyvenv/pyvenv-1.21.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Python virtual environment interface for Emacs"
+HOMEPAGE="https://github.com/jorgenschaefer/pyvenv/"
+SRC_URI="https://github.com/jorgenschaefer/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/mocker )"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ # Other tests require special Python Venv setup
+ ${EMACS} ${EMACSFLAGS} -L . -l ./${PN}.el -L ./test \
+ -l ./test/pyvenv-mode-test.el -l ./test/pyvenv-hook-dir-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}