summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-03 01:37:52 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-03 01:48:49 +0200
commit5c13f5f258cff0078da349aa36a321f77963d67b (patch)
tree57ff0df1eb6ab7fa5ea8ed9741b9090252a769e9 /app-emacs/tempel
parentapp-emacs/osm: bump to 0.13 (diff)
downloadgentoo-5c13f5f258cff0078da349aa36a321f77963d67b.tar.gz
gentoo-5c13f5f258cff0078da349aa36a321f77963d67b.tar.bz2
gentoo-5c13f5f258cff0078da349aa36a321f77963d67b.zip
app-emacs/tempel: bump to 0.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/tempel')
-rw-r--r--app-emacs/tempel/Manifest1
-rw-r--r--app-emacs/tempel/tempel-0.8.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/tempel/Manifest b/app-emacs/tempel/Manifest
index 66d6decf80fd..9695fcd3b60a 100644
--- a/app-emacs/tempel/Manifest
+++ b/app-emacs/tempel/Manifest
@@ -1,2 +1,3 @@
DIST tempel-0.6.tar.gz 25563 BLAKE2B 2edd522335f8faaa989b313b04f394f30f514cf7c40ec20f5f5fe0c1f1fe1b3ae05d15e9deb103e94d3d25b86a5725caa78904a25f22f806453a705dfc5e9c82 SHA512 49938758f5289fc9c77a78dc1559ce6a454d5969b256ba0e18239855ff0667afbb131c8e2214d4994fc342397903a293ad88bf26828c693ec5e197174d78ef50
DIST tempel-0.7.tar.gz 26541 BLAKE2B 81bd7cd734eba5fbe299c736133512c035439036e17dc032b865c29e30ad6837957af8ce9bde3d56bc3dccb12f2e6111e66605e72e0bb0eead982fb436d8e9e1 SHA512 3589962c3273e9a2fb8a3b2d59c8831e15b481b9e69ad7785ae5a30e4df133bb187da6e58c04d77fa37b217f2a7c68dd7825c8a20856320f824adf739e5629a3
+DIST tempel-0.8.tar.gz 27043 BLAKE2B f4920a1c0d1d7ed21f2681031f846b07fcdabbd59b76f3ba2fcd1277c78b30e1c5e134deeb35410f7227d753256b9c16c6a4d641011b99d87b49f0fae0fd5a04 SHA512 7b832e151821f4c72a3d14663fb76a956e2b6730387e71e1aedb52c72a7798a5804ad2ca3d63185c52d39128d748394419c3708d8a6a7497014e573d277fa5d9
diff --git a/app-emacs/tempel/tempel-0.8.ebuild b/app-emacs/tempel/tempel-0.8.ebuild
new file mode 100644
index 000000000000..51f816d019d3
--- /dev/null
+++ b/app-emacs/tempel/tempel-0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Templates with in-buffer field editing for GNU Emacs"
+HOMEPAGE="https://github.com/minad/tempel/"
+SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}