summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-31 16:54:03 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-31 17:09:50 +0200
commit2a873004fd2632a49aa1c51a64714c441c59c976 (patch)
treeda33bc802ca7c24a9b988346f5867537901aada8 /app-emacs/vertico
parentapp-emacs/s: bump to 1.13.0 (diff)
downloadgentoo-2a873004fd2632a49aa1c51a64714c441c59c976.tar.gz
gentoo-2a873004fd2632a49aa1c51a64714c441c59c976.tar.bz2
gentoo-2a873004fd2632a49aa1c51a64714c441c59c976.zip
app-emacs/vertico: bump to 0.26
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/vertico')
-rw-r--r--app-emacs/vertico/Manifest1
-rw-r--r--app-emacs/vertico/vertico-0.26.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
index 82e95501fcea..2f3c4a598345 100644
--- a/app-emacs/vertico/Manifest
+++ b/app-emacs/vertico/Manifest
@@ -1,2 +1,3 @@
DIST vertico-0.24.tar.gz 42777 BLAKE2B 64e3f11dfb425c814665b49d755a52db4146c875969be7621539892f72df6ef9c4186be05373230b48369f1e2e85aee8e97cb829afe3618b9507170c4a8ca1a0 SHA512 67edb7e45e257c2cdf53d7adb2b29eed8cb3a1ac42dcec41bd555d553c60e4fc9806c6ad51b5cc183abb1d3967a4f43ab0e4ce0d317f77eb4d7cdedb9ea39834
DIST vertico-0.25.tar.gz 42765 BLAKE2B cb87a0226b741f2e7b1e90b339debfef3caa4abc89dc5aecaee1c7a76ac7db6fdc4f13019ba6993f696735d4b020aa06caabf497f6e9b2047b24dd4e434a176a SHA512 aa2ae45f93412e45ed9da0382ce69a2a7a18196f80789915bfbf9edb1593f5d5ae3370d2f0c03059ef7eb38cb664052fb0a49172f51e304bc389df439a51ad61
+DIST vertico-0.26.tar.gz 43410 BLAKE2B d8967dad143066dcf288d9cb103d9a66732262598867f4d7184e6c2b1c7fd98629b0e0fe012f7c9960a3e194656507ff3150bcc372258b0c45c839aae2506ae6 SHA512 a4246169db6f8f8e2f65e8b8f1c3c5a52e29d226b92cf30ff968a44f9293e4c6dceaf567516066e3d1e5212edf7c4a25825719072d3c2bbffca9967a500e7605
diff --git a/app-emacs/vertico/vertico-0.26.ebuild b/app-emacs/vertico/vertico-0.26.ebuild
new file mode 100644
index 000000000000..eec14ff439d5
--- /dev/null
+++ b/app-emacs/vertico/vertico-0.26.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}