summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-03 09:51:12 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-03 09:58:49 +0200
commit5b7afb2031ea9f783da1a25e18172effa01efd57 (patch)
treed698c84f90824364b25fa49a4df0ca2f0b878fa2 /app-emacs
parentapp-emacs/consult: enable live (diff)
downloadgentoo-5b7afb2031ea9f783da1a25e18172effa01efd57.tar.gz
gentoo-5b7afb2031ea9f783da1a25e18172effa01efd57.tar.bz2
gentoo-5b7afb2031ea9f783da1a25e18172effa01efd57.zip
app-emacs/consult: add live
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/consult/consult-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/consult/consult-9999.ebuild b/app-emacs/consult/consult-9999.ebuild
new file mode 100644
index 000000000000..7b1398601c9b
--- /dev/null
+++ b/app-emacs/consult/consult-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read for GNU Emacs"
+HOMEPAGE="https://github.com/minad/consult/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-28.1"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}