summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-06 22:34:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-06 23:18:19 +0100
commit9e16db1a39c1cbba6801529a20dcb6e829decb80 (patch)
tree5402b477e3040ca4fde717972952bf34fd3452c2 /app-emacs
parentapp-office/joplin-desktop: bump to 3.2.6 (diff)
downloadgentoo-9e16db1a39c1cbba6801529a20dcb6e829decb80.tar.gz
gentoo-9e16db1a39c1cbba6801529a20dcb6e829decb80.tar.bz2
gentoo-9e16db1a39c1cbba6801529a20dcb6e829decb80.zip
app-emacs/compat: bump to 30.0.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-30.0.2.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 099613812f0e..337bf4f24898 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,2 +1,3 @@
DIST compat-30.0.0.0.tar.gz 140329 BLAKE2B 7de4dffc518e521d0c15d3deb0f544972eb6660e19e3028f956b39b9ce355901f3d39339d9f2060a3b7754d67ec9ce92a720cc83afc468f3a2cedc189d8eb922 SHA512 04e2c26f6c1fbb78fc0f2de70913694b3f37614a6992b2a36cec5288c2083481701bdfb7d7e981582c8b22cf61b71e5a3e6011f86c1602331a26ad61c1fe2f66
DIST compat-30.0.1.0.tar.gz 142477 BLAKE2B dc0f912f8c019846a6dde9c3013527589cb7b8f21cbc3478c16f0dd0edfca15a71f67df91b417ff26a401954b047bc7f6a7fc8efd6d874e3e96e17cf3acd16dd SHA512 cbab795c8ef890307eb6e161d900948a84948ea4b2462056a39ca21e8a4d0aebc985f7ff536658156e9d6e760e33b2b234bc2460f64193b9d07b733a267c1dfe
+DIST compat-30.0.2.0.tar.gz 142328 BLAKE2B aed05c7b352076a455185760e2a90515f15e4606d2845791ec7e77e89724bc6177cca6669d5f7955b6d1c728824502e634340b0db12cd800b6e61c567e20ae73 SHA512 4706d161e352987897cf23bd50c9afdb4e861e39f829031a0f5c4693c8c0b84a181ec1a21023438d0d3b85d2164edcdd839bacb11ef158ec60d4a945d7b1d436
diff --git a/app-emacs/compat/compat-30.0.2.0.ebuild b/app-emacs/compat/compat-30.0.2.0.ebuild
new file mode 100644
index 000000000000..dca8f1fa5a52
--- /dev/null
+++ b/app-emacs/compat/compat-30.0.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-compat/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ sys-apps/texinfo
+"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}
+
+src_install() {
+ rm ./compat-tests.el || die
+
+ elisp_src_install
+}