summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-26 10:20:57 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-26 10:31:27 +0200
commit9fee34c9cc1ada4d5bb5729338b79f43f8e25570 (patch)
treebff250afe409d4071292f9d0ba85d680acfddd7a /app-emacs
parentsci-libs/med: drop 4.1.0 (diff)
downloadgentoo-9fee34c9cc1ada4d5bb5729338b79f43f8e25570.tar.gz
gentoo-9fee34c9cc1ada4d5bb5729338b79f43f8e25570.tar.bz2
gentoo-9fee34c9cc1ada4d5bb5729338b79f43f8e25570.zip
app-emacs/emacs-ipython-notebook: correctly depend on py packages
fix QA - correctly depend on python packages Closes: https://bugs.gentoo.org/872986 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419-r1.ebuild (renamed from app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419.ebuild)20
1 files changed, 15 insertions, 5 deletions
diff --git a/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419.ebuild b/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419-r1.ebuild
index e04873c402a4..1d67af472a51 100644
--- a/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419.ebuild
+++ b/app-emacs/emacs-ipython-notebook/emacs-ipython-notebook-0.17.0_p20220419-r1.ebuild
@@ -8,8 +8,9 @@ EAPI=8
H=388c8f753cfb99b4f82acbdff26bbe27189d2299
NEED_EMACS=25
+PYTHON_COMPAT=( python3_{8..10} )
-inherit elisp readme.gentoo-r1
+inherit elisp readme.gentoo-r1 python-single-r1
DESCRIPTION="Jupyter notebook client in Emacs"
HOMEPAGE="https://github.com/millejoh/emacs-ipython-notebook/"
@@ -21,8 +22,10 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
+ ${PYTHON_DEPS}
app-emacs/anaphora
app-emacs/dash
app-emacs/deferred
@@ -30,9 +33,11 @@ RDEPEND="
app-emacs/request
app-emacs/websocket
app-emacs/with-editor
- dev-python/ipython
- dev-python/notebook
- dev-python/tornado
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ ')
"
BDEPEND="
${RDEPEND}
@@ -52,13 +57,18 @@ DOC_CONTENTS="There may be problems with connecting to Jupyter Notebooks
SITEFILE="50${PN}-gentoo.el"
+pkg_setup() {
+ elisp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
src_compile() {
BYTECOMPFLAGS="-L lisp" elisp-compile lisp/*.el
}
src_test() {
ert-runner -L lisp -L test -l test/testein.el \
- --reporter ert+duration test/test-ein*.el || die
+ --reporter ert+duration test/test-ein*.el || die
}
src_install() {