summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-10 17:21:30 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-10 20:16:32 +0200
commitb37aedde2d1468e38e710ee40075dc45653be5ae (patch)
tree598a11a47e0fd5d4948928e11bf448d50576baa9 /app-emacs
parentapp-emacs/emacsql: bump to 4.0.0 (diff)
downloadgentoo-b37aedde2d1468e38e710ee40075dc45653be5ae.tar.gz
gentoo-b37aedde2d1468e38e710ee40075dc45653be5ae.tar.bz2
gentoo-b37aedde2d1468e38e710ee40075dc45653be5ae.zip
app-emacs/ghub: bump to 4.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ghub/Manifest1
-rw-r--r--app-emacs/ghub/ghub-4.0.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/ghub/Manifest b/app-emacs/ghub/Manifest
index 9c4177794811..11174ef162f1 100644
--- a/app-emacs/ghub/Manifest
+++ b/app-emacs/ghub/Manifest
@@ -1 +1,2 @@
DIST ghub-3.6.0.tar.gz 62572 BLAKE2B 5693177be9ac22d18b7b6f5cdc230eea4340a5bfd007fa4b18f3503fe796fd8b104753be51c8579de6e693cfc620c4524dae195627af4c542bd2fe94aad1d0dd SHA512 e54752f70c462ce4fed3a1fc3ca60f22107e2acaefb06ebf42d35c6b65f9091bba07ff72436310782d9be7fbf35aef473dbbe39ef7a4ac3de1ebd82a417c6b0a
+DIST ghub-4.0.0.tar.gz 63020 BLAKE2B e01df9e093573933e24c39ef9a252d31dda4c9b0304ad5ab1f5ba55b6869224bb708dbdc0994c316c35ac0bb8df08d7238da0469a7e0ff84f3f769d35b55d89e SHA512 61825bd5230bc4a80c4a0a40cb717fd4a603ac351a3cdae2bc93fa0e8ca6d4ba51647d8cb151e436a8b19def7a389629dddebb1454172588a472bf0eb2c21b8e
diff --git a/app-emacs/ghub/ghub-4.0.0.ebuild b/app-emacs/ghub/ghub-4.0.0.ebuild
new file mode 100644
index 000000000000..4a4eeabd3d10
--- /dev/null
+++ b/app-emacs/ghub/ghub-4.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minuscule client library for the Git forge APIs"
+HOMEPAGE="https://magit.vc/manual/ghub/
+ https://github.com/magit/ghub/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+ELISP_TEXINFO="docs/ghub.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/treepy-0.1.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ default
+
+ mv lisp/*.el . || die
+ rm ghub-pkg.el || die
+}