summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-11 01:03:35 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-11 01:28:42 +0100
commitc1658453d1ae7be5e843042a9e7a9432b26c0c93 (patch)
treea20ab75c206c8507cba56facb1b2f36794d754c2 /app-emacs
parentapp-emacs/forge: bump to 0.4.5 (diff)
downloadgentoo-c1658453d1ae7be5e843042a9e7a9432b26c0c93.tar.gz
gentoo-c1658453d1ae7be5e843042a9e7a9432b26c0c93.tar.bz2
gentoo-c1658453d1ae7be5e843042a9e7a9432b26c0c93.zip
app-emacs/ghub: bump to 4.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ghub/Manifest1
-rw-r--r--app-emacs/ghub/ghub-4.2.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/ghub/Manifest b/app-emacs/ghub/Manifest
index d5ca19e6e841..b3ce1ad1a02d 100644
--- a/app-emacs/ghub/Manifest
+++ b/app-emacs/ghub/Manifest
@@ -1 +1,2 @@
DIST ghub-4.1.1.tar.gz 63350 BLAKE2B da6ca76f7980887ee7ce5ce7c5482b8314f6fa1b051c906200d72bfcbf787505e5310ca91c47eb762e7d6a6f8b604e86828aabe023a5f451d11513dd2b9ae2b4 SHA512 cb9312956f856a99ef74a53a2c42d9da4e6722ce051eda78910054df64d5a6f8cf847542a56bb81d146ff6028363eda4e98a44ec4ca34c59a0eff893fc654b47
+DIST ghub-4.2.0.tar.gz 61058 BLAKE2B 055edcd4deaa068874ca896027bd752fac099a355f0b19be6bae75c8b1eaffe43206e5ab92cddaa35103040d2eb5533034bccff494e7c364382c164d5f6a1735 SHA512 530a19bbbd3d7dfb9f1289f0a1273f08f741f87a4009db0ffc08a4ec1fa7f1d1c3468692277f494334d21b869730d10abf7005f7cfeb50b76df9ab4a3f3d7328
diff --git a/app-emacs/ghub/ghub-4.2.0.ebuild b/app-emacs/ghub/ghub-4.2.0.ebuild
new file mode 100644
index 000000000000..137580e04d5e
--- /dev/null
+++ b/app-emacs/ghub/ghub-4.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minuscule client library for the Git forge APIs"
+HOMEPAGE="https://magit.vc/manual/ghub/
+ https://github.com/magit/ghub/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+ELISP_TEXINFO="docs/ghub.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/treepy-0.1.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ elisp_src_prepare
+}