summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Słomiński <kacper.slominski72@gmail.com>2024-09-24 08:17:45 +0200
committerSam James <sam@gentoo.org>2024-09-24 07:31:57 +0100
commitfe861bad915ba95e8f1f66851efe897e90ad5084 (patch)
tree37e7cca2d106558f5ccbfdf8cd16a75b522c143b /app-emacs
parentapp-emacs/geiser-guile: add 0.28.3-r100 (diff)
downloadgentoo-fe861bad915ba95e8f1f66851efe897e90ad5084.tar.gz
gentoo-fe861bad915ba95e8f1f66851efe897e90ad5084.tar.bz2
gentoo-fe861bad915ba95e8f1f66851efe897e90ad5084.zip
app-emacs/flycheck-guile: add 0.5-r100
Signed-off-by: Kacper Słomiński <kacper.slominski72@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38754 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/flycheck-guile/flycheck-guile-0.5-r100.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/flycheck-guile/flycheck-guile-0.5-r100.ebuild b/app-emacs/flycheck-guile/flycheck-guile-0.5-r100.ebuild
new file mode 100644
index 000000000000..145e7ffaaf86
--- /dev/null
+++ b/app-emacs/flycheck-guile/flycheck-guile-0.5-r100.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_COMPAT=( 2-2 3-0 )
+
+inherit elisp guile-single
+
+DESCRIPTION="Flycheck checker for the GNU Guile Scheme implementation"
+HOMEPAGE="https://github.com/flatwhatson/flycheck-guile/"
+SRC_URI="https://github.com/flatwhatson/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+REQUIRED_USE="${GUILE_REQUIRED_USE}"
+
+BDEPEND="
+ app-emacs/flycheck
+ app-emacs/geiser-guile
+"
+RDEPEND="
+ ${BDEPEND}
+ ${GUILE_DEPS}
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|\"guild\"|\"${GUILD}\"|" -i "${PN}.el" || die
+}
+
+src_install() {
+ elisp_src_install
+}