summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-25 12:19:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 18:02:22 +0100
commitc9a875a5033ae3bf563c9136d0dd120f9c696e2e (patch)
tree295de29c89326bf73297d8104ed7d89668aa8a43 /app-emulation/faudio/faudio-9999.ebuild
parentdev-python/keyring: Bump to 23.0.0 (diff)
downloadgentoo-c9a875a5033ae3bf563c9136d0dd120f9c696e2e.tar.gz
gentoo-c9a875a5033ae3bf563c9136d0dd120f9c696e2e.tar.bz2
gentoo-c9a875a5033ae3bf563c9136d0dd120f9c696e2e.zip
app-emulation/faudio: Switch to cmake.eclass
Drop superfluous COMMON_DEPEND Drop superfluous CMAKE_INSTALL_PREFIX, set by cmake.eclass Use of CMAKE_INSTALL_<dir> variables looks like a workaround of wrong upstream usage of GNUInstallDirs but should be fixed upstream. Closes: https://bugs.gentoo.org/770532 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-emulation/faudio/faudio-9999.ebuild')
-rw-r--r--app-emulation/faudio/faudio-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/app-emulation/faudio/faudio-9999.ebuild b/app-emulation/faudio/faudio-9999.ebuild
index 52c652a59596..51ecd606fc26 100644
--- a/app-emulation/faudio/faudio-9999.ebuild
+++ b/app-emulation/faudio/faudio-9999.ebuild
@@ -4,6 +4,7 @@
# shellcheck disable=SC2034
EAPI=7
+CMAKE_ECLASS=cmake
CMAKE_MAKEFILE_GENERATOR="emake"
MULTILIB_COMPAT=( abi_x86_{32,64} )
@@ -31,24 +32,20 @@ IUSE="+abi_x86_32 +abi_x86_64 debug dumpvoices gstreamer xnasong test utils"
RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
-COMMON_DEPEND="
+DEPEND="
>=media-libs/libsdl2-2.0.9[sound,${MULTILIB_USEDEP}]
gstreamer? (
media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}]
)
"
-RDEPEND="${COMMON_DEPEND}
-"
-DEPEND="${COMMON_DEPEND}
-"
+RDEPEND="${DEPEND}"
multilib_src_configure() {
local mycmakeargs=(
"-DCMAKE_INSTALL_BINDIR=bin"
"-DCMAKE_INSTALL_INCLUDEDIR=include/${FAUDIO_PN}"
"-DCMAKE_INSTALL_LIBDIR=$(get_libdir)"
- "-DCMAKE_INSTALL_PREFIX=${EPREFIX}/usr"
"-DCMAKE_BUILD_TYPE=$(usex debug Debug Release)"
"-DFORCE_ENABLE_DEBUGCONFIGURATION=$(usex debug ON OFF)"
"-DBUILD_TESTS=$(usex test ON OFF)"
@@ -57,7 +54,7 @@ multilib_src_configure() {
"-DGSTREAMER=$(usex gstreamer ON OFF)"
"-DXNASONG=$(usex xnasong ON OFF)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_configure() {
@@ -65,13 +62,13 @@ src_configure() {
}
multilib_src_compile() {
- cmake-utils_src_make
+ cmake_build
emake -C "${BUILD_DIR}" all
}
multilib_src_install() {
# FIXME: do we want to install the FAudio tools?
- cmake-utils_src_install
+ cmake_src_install
sed -e "s@%LIB%@$(get_libdir)@g" -e "s@%PREFIX%@${EPREFIX}/usr@g" \
"${FILESDIR}/faudio.pc" > "${T}/faudio.pc" \