summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2024-03-23 17:44:22 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-06 08:29:15 +0300
commitb4b332b610d6c55ce95749597032b9d9a80e95de (patch)
treee5a224bd737d4eb0ad2238dd60a23e1ee54d4b5c /app-emulation/punes
parentapp-office/lyx: fix external mythes on debug builds (diff)
downloadgentoo-b4b332b610d6c55ce95749597032b9d9a80e95de.tar.gz
gentoo-b4b332b610d6c55ce95749597032b9d9a80e95de.tar.bz2
gentoo-b4b332b610d6c55ce95749597032b9d9a80e95de.zip
app-emulation/punes: fix compilation with USE="-X"
Closes: https://bugs.gentoo.org/927477 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35878 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-emulation/punes')
-rw-r--r--app-emulation/punes/files/punes-0.111-FULLSCREEN_RESFREQ-fix.patch33
-rw-r--r--app-emulation/punes/punes-0.111.ebuild4
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/punes/files/punes-0.111-FULLSCREEN_RESFREQ-fix.patch b/app-emulation/punes/files/punes-0.111-FULLSCREEN_RESFREQ-fix.patch
new file mode 100644
index 000000000000..065483ad058f
--- /dev/null
+++ b/app-emulation/punes/files/punes-0.111-FULLSCREEN_RESFREQ-fix.patch
@@ -0,0 +1,33 @@
+From e1516fcefe3dcc9710ae85cce0f536fd2d9fdcd6 Mon Sep 17 00:00:00 2001
+From: Fabio Cavallo <punes.development@gmail.com>
+Date: Sat, 23 Mar 2024 10:34:34 +0100
+Subject: [PATCH] Fixed compilation with FULLSCREEN_RESFREQ disabled (#388).
+
+--- a/src/core/emu.c
++++ b/src/core/emu.c
+@@ -43,11 +43,11 @@
+ #include "recent_roms.h"
+ #include "../../c++/crc/crc.h"
+ #include "gui.h"
++#include "nes20db.h"
+ #include "video/effects/pause.h"
+ #include "video/effects/tv_noise.h"
+ #if defined (FULLSCREEN_RESFREQ)
+ #include "video/gfx_monitor.h"
+-#include "nes20db.h"
+ #endif
+
+ #define RS_SCALE (1.0f / (1.0f + (float)RAND_MAX))
+--- a/src/gui/wdgOverlayUi.cpp
++++ b/src/gui/wdgOverlayUi.cpp
+@@ -34,9 +34,9 @@
+ #include "rewind.h"
+ #include "version.h"
+ #include "nes.h"
++#include "input/standard_controller.h"
+ #if defined (FULLSCREEN_RESFREQ)
+ #include "video/gfx_monitor.h"
+-#include "input/standard_controller.h"
+ #endif
+
+ void overlay_info_append_qstring(BYTE alignment, const QString &msg);
diff --git a/app-emulation/punes/punes-0.111.ebuild b/app-emulation/punes/punes-0.111.ebuild
index 16b8811e4a80..03071411bec5 100644
--- a/app-emulation/punes/punes-0.111.ebuild
+++ b/app-emulation/punes/punes-0.111.ebuild
@@ -46,6 +46,10 @@ BDEPEND="
qt6? ( dev-qt/qttools[linguist] )
!qt6? ( dev-qt/linguist-tools:5 )"
+PATCHES=(
+ "${FILESDIR}/punes-0.111-FULLSCREEN_RESFREQ-fix.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DENABLE_GIT_INFO=OFF