summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-11 01:05:38 +0100
committerSam James <sam@gentoo.org>2024-09-11 01:05:38 +0100
commit943a450e07e1a1959b34354faad06541dd515c12 (patch)
tree7bb871ca8a9d2150dde40e52d2717918a65076c5 /app-emulation/qemu
parentprofiles.desc: Switch all glibc mips profiles to stable or dev, and some musl... (diff)
downloadgentoo-943a450e07e1a1959b34354faad06541dd515c12.tar.gz
gentoo-943a450e07e1a1959b34354faad06541dd515c12.tar.bz2
gentoo-943a450e07e1a1959b34354faad06541dd515c12.zip
app-emulation/qemu: fix systemtap has_version check
Bug: https://bugs.gentoo.org/938302 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-7.2.11.ebuild2
-rw-r--r--app-emulation/qemu/qemu-7.2.12.ebuild2
-rw-r--r--app-emulation/qemu/qemu-7.2.13.ebuild2
-rw-r--r--app-emulation/qemu/qemu-8.0.5.ebuild2
-rw-r--r--app-emulation/qemu/qemu-8.1.5.ebuild2
-rw-r--r--app-emulation/qemu/qemu-8.2.3.ebuild2
-rw-r--r--app-emulation/qemu/qemu-8.2.5-r1.ebuild2
-rw-r--r--app-emulation/qemu/qemu-8.2.6-r1.ebuild2
-rw-r--r--app-emulation/qemu/qemu-9.0.1-r1.ebuild2
-rw-r--r--app-emulation/qemu/qemu-9.0.2-r1.ebuild2
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild2
11 files changed, 11 insertions, 11 deletions
diff --git a/app-emulation/qemu/qemu-7.2.11.ebuild b/app-emulation/qemu/qemu-7.2.11.ebuild
index 5a9af9426352..e928b05fcd7d 100644
--- a/app-emulation/qemu/qemu-7.2.11.ebuild
+++ b/app-emulation/qemu/qemu-7.2.11.ebuild
@@ -452,7 +452,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-7.2.12.ebuild b/app-emulation/qemu/qemu-7.2.12.ebuild
index d9dab196a8bb..f36330d37cf1 100644
--- a/app-emulation/qemu/qemu-7.2.12.ebuild
+++ b/app-emulation/qemu/qemu-7.2.12.ebuild
@@ -452,7 +452,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-7.2.13.ebuild b/app-emulation/qemu/qemu-7.2.13.ebuild
index d9dab196a8bb..f36330d37cf1 100644
--- a/app-emulation/qemu/qemu-7.2.13.ebuild
+++ b/app-emulation/qemu/qemu-7.2.13.ebuild
@@ -452,7 +452,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-8.0.5.ebuild b/app-emulation/qemu/qemu-8.0.5.ebuild
index d1a99943c1f8..9db811fb45c2 100644
--- a/app-emulation/qemu/qemu-8.0.5.ebuild
+++ b/app-emulation/qemu/qemu-8.0.5.ebuild
@@ -455,7 +455,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-8.1.5.ebuild b/app-emulation/qemu/qemu-8.1.5.ebuild
index f25b0b58db19..5aacea78586a 100644
--- a/app-emulation/qemu/qemu-8.1.5.ebuild
+++ b/app-emulation/qemu/qemu-8.1.5.ebuild
@@ -456,7 +456,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-8.2.3.ebuild b/app-emulation/qemu/qemu-8.2.3.ebuild
index cd2bb3a7f555..570039efaff5 100644
--- a/app-emulation/qemu/qemu-8.2.3.ebuild
+++ b/app-emulation/qemu/qemu-8.2.3.ebuild
@@ -476,7 +476,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-8.2.5-r1.ebuild b/app-emulation/qemu/qemu-8.2.5-r1.ebuild
index 0f6b1a184aa7..97bf795e95b8 100644
--- a/app-emulation/qemu/qemu-8.2.5-r1.ebuild
+++ b/app-emulation/qemu/qemu-8.2.5-r1.ebuild
@@ -476,7 +476,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-8.2.6-r1.ebuild b/app-emulation/qemu/qemu-8.2.6-r1.ebuild
index 0f6b1a184aa7..97bf795e95b8 100644
--- a/app-emulation/qemu/qemu-8.2.6-r1.ebuild
+++ b/app-emulation/qemu/qemu-8.2.6-r1.ebuild
@@ -476,7 +476,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-9.0.1-r1.ebuild b/app-emulation/qemu/qemu-9.0.1-r1.ebuild
index 10d7d289766a..2fe9ba5dd5f1 100644
--- a/app-emulation/qemu/qemu-9.0.1-r1.ebuild
+++ b/app-emulation/qemu/qemu-9.0.1-r1.ebuild
@@ -480,7 +480,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-9.0.2-r1.ebuild b/app-emulation/qemu/qemu-9.0.2-r1.ebuild
index 10d7d289766a..2fe9ba5dd5f1 100644
--- a/app-emulation/qemu/qemu-9.0.2-r1.ebuild
+++ b/app-emulation/qemu/qemu-9.0.2-r1.ebuild
@@ -480,7 +480,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index b99578e9089e..978471403537 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -479,7 +479,7 @@ src_prepare() {
export WINDRES=${CHOST}-windres
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
cat >> "${S}"/configs/meson/linux.txt <<-EOF || die
[binaries]
dtrace='stap-dtrace'