summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-08 09:17:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-08 09:17:48 +0100
commit9ab61b9162819825424a6f30edb0a2d3290fd56f (patch)
treefba5c8ba4a68d361fa344612e8ec2327ade93ce9 /app-emulation/qemu
parentdev-perl/File-chmod: -r bump for EAPI7 + fixes (diff)
downloadgentoo-9ab61b9162819825424a6f30edb0a2d3290fd56f.tar.gz
gentoo-9ab61b9162819825424a6f30edb0a2d3290fd56f.tar.bz2
gentoo-9ab61b9162819825424a6f30edb0a2d3290fd56f.zip
app-emulation/qemu: enable sdl-image only for softmmu
qemu's build system became sightly stricter and disallows 'sdl-image' support without 'sdl' support. The check only makes sense for softmmu build, but is done for all types of builds. The change disables 'sdl-image' flag for 'user' and 'tools' builds. Reported-by: Rafael Kitover Closes: https://bugs.gentoo.org/740836 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index da2bd1246efe..df162166cbf8 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -445,6 +445,14 @@ qemu_src_configure() {
use_enable "$@"
fi
}
+ # Ennable option only for softmmu build, but not 'user' or 'tools'
+ conf_softmmu() {
+ if [[ ${buildtype} == "softmmu" ]] ; then
+ use_enable "$@"
+ else
+ echo "--disable-${2:-$1}"
+ fi
+ }
conf_opts+=(
$(conf_notuser accessibility brlapi)
$(conf_notuser aio linux-aio)
@@ -473,7 +481,7 @@ qemu_src_configure() {
$(conf_notuser rbd)
$(conf_notuser sasl vnc-sasl)
$(conf_notuser sdl)
- $(conf_notuser sdl-image)
+ $(conf_softmmu sdl-image)
$(conf_notuser seccomp)
$(conf_notuser slirp slirp system)
$(conf_notuser smartcard)