summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:24:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:12 +0100
commit2111aecf2f5986f17026474a8d4405565fb1a379 (patch)
tree5eb3669b851432daa85b5889d5af3cca93626a13 /app-emulation/virt-manager
parentapp-emulation/protontricks: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-2111aecf2f5986f17026474a8d4405565fb1a379.tar.gz
gentoo-2111aecf2f5986f17026474a8d4405565fb1a379.tar.bz2
gentoo-2111aecf2f5986f17026474a8d4405565fb1a379.zip
app-emulation/virt-manager: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-emulation/virt-manager')
-rw-r--r--app-emulation/virt-manager/virt-manager-2.0.0.ebuild14
-rw-r--r--app-emulation/virt-manager/virt-manager-2.2.0.ebuild14
-rw-r--r--app-emulation/virt-manager/virt-manager-2.2.1-r1.ebuild (renamed from app-emulation/virt-manager/virt-manager-2.2.1.ebuild)12
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild14
4 files changed, 31 insertions, 23 deletions
diff --git a/app-emulation/virt-manager/virt-manager-2.0.0.ebuild b/app-emulation/virt-manager/virt-manager-2.0.0.ebuild
index 0dedfe355424..05fb004334b4 100644
--- a/app-emulation/virt-manager/virt-manager-2.0.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-2.0.0.ebuild
@@ -29,12 +29,14 @@ RDEPEND="!app-emulation/virtinst
${PYTHON_DEPS}
app-cdr/cdrtools
>=app-emulation/libvirt-glib-1.0.0[introspection]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- dev-python/argcomplete[${PYTHON_USEDEP}]
- dev-python/ipaddr[${PYTHON_USEDEP}]
- dev-python/libvirt-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
+ dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+ dev-python/libvirt-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
>=sys-libs/libosinfo-0.2.10[introspection]
gtk? (
gnome-base/dconf
diff --git a/app-emulation/virt-manager/virt-manager-2.2.0.ebuild b/app-emulation/virt-manager/virt-manager-2.2.0.ebuild
index b5b58cd52a7e..ef3ad18879d6 100644
--- a/app-emulation/virt-manager/virt-manager-2.2.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-2.2.0.ebuild
@@ -29,12 +29,14 @@ RDEPEND="!app-emulation/virtinst
${PYTHON_DEPS}
app-cdr/cdrtools
>=app-emulation/libvirt-glib-1.0.0[introspection]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- dev-python/argcomplete[${PYTHON_USEDEP}]
- dev-python/ipaddr[${PYTHON_USEDEP}]
- dev-python/libvirt-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
+ dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+ dev-python/libvirt-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
>=sys-libs/libosinfo-0.2.10[introspection]
gtk? (
gnome-base/dconf
diff --git a/app-emulation/virt-manager/virt-manager-2.2.1.ebuild b/app-emulation/virt-manager/virt-manager-2.2.1-r1.ebuild
index 9730435dcad8..963b5ecd8dab 100644
--- a/app-emulation/virt-manager/virt-manager-2.2.1.ebuild
+++ b/app-emulation/virt-manager/virt-manager-2.2.1-r1.ebuild
@@ -29,11 +29,13 @@ RDEPEND="!app-emulation/virtinst
${PYTHON_DEPS}
app-cdr/cdrtools
>=app-emulation/libvirt-glib-1.0.0[introspection]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- dev-python/ipaddr[${PYTHON_USEDEP}]
- dev-python/libvirt-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+ dev-python/libvirt-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
>=sys-libs/libosinfo-0.2.10[introspection]
gtk? (
gnome-base/dconf
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index ca5fdb8b22af..91e2bbc0f7cc 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -29,12 +29,14 @@ RDEPEND="!app-emulation/virtinst
${PYTHON_DEPS}
app-cdr/cdrtools
>=app-emulation/libvirt-glib-1.0.0[introspection]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- dev-python/argcomplete[${PYTHON_USEDEP}]
- dev-python/ipaddr[${PYTHON_USEDEP}]
- dev-python/libvirt-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
+ dev-python/ipaddr[${PYTHON_MULTI_USEDEP}]
+ dev-python/libvirt-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
>=sys-libs/libosinfo-0.2.10[introspection]
gtk? (
gnome-base/dconf