summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Tortuyaux <mtortuyaux@microsoft.com>2021-10-01 16:14:34 +0200
committerWilliam Hubbs <williamh@gentoo.org>2021-10-01 23:03:47 -0500
commit0a3655d676cb95bf0be1dc039c20349bb3d74ce6 (patch)
treeb7cec99db86788f80a571e9bb8bb6b034d249a17 /app-emulation
parentsys-kernel/gentoo-kernel-bin: add 5.14.9-r1 for arm64 (diff)
downloadgentoo-0a3655d676cb95bf0be1dc039c20349bb3d74ce6.tar.gz
gentoo-0a3655d676cb95bf0be1dc039c20349bb3d74ce6.tar.bz2
gentoo-0a3655d676cb95bf0be1dc039c20349bb3d74ce6.zip
app-emulation/docker-cli: use `${PV}` for CLI version
Upstream isn't updating the file regularly, so use ${PV}. Closes: https://bugs.gentoo.org/815658 Closes: https://github.com/gentoo/gentoo/pull/22457 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Mathieu Tortuyaux <mtortuyaux@microsoft.com> Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-cli/docker-cli-20.10.7.ebuild2
-rw-r--r--app-emulation/docker-cli/docker-cli-20.10.8.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/app-emulation/docker-cli/docker-cli-20.10.7.ebuild b/app-emulation/docker-cli/docker-cli-20.10.7.ebuild
index ab025371c183..89c5fce7feaa 100644
--- a/app-emulation/docker-cli/docker-cli-20.10.7.ebuild
+++ b/app-emulation/docker-cli/docker-cli-20.10.7.ebuild
@@ -37,7 +37,7 @@ src_compile() {
export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
emake \
LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
- VERSION="$(cat VERSION)" \
+ VERSION="${PV}" \
GITCOMMIT="${GIT_COMMIT}" \
dynbinary
diff --git a/app-emulation/docker-cli/docker-cli-20.10.8.ebuild b/app-emulation/docker-cli/docker-cli-20.10.8.ebuild
index 1e802fb5d247..849c68107792 100644
--- a/app-emulation/docker-cli/docker-cli-20.10.8.ebuild
+++ b/app-emulation/docker-cli/docker-cli-20.10.8.ebuild
@@ -39,7 +39,7 @@ src_compile() {
export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
emake \
LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
- VERSION="$(cat VERSION)" \
+ VERSION="${PV}" \
GITCOMMIT="${GIT_COMMIT}" \
dynbinary