summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-10-16 12:42:40 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-10-16 12:42:40 +0100
commit3e26dd9088a0c10ba11063d0b6b8eaf61fa6b347 (patch)
tree466265053b98f2e72aaec34a772439783cb79503 /app-emulation
parentapp-emulation/fs-uae: Version bump to 3.1.35, EAPI 8 (diff)
downloadgentoo-3e26dd9088a0c10ba11063d0b6b8eaf61fa6b347.tar.gz
gentoo-3e26dd9088a0c10ba11063d0b6b8eaf61fa6b347.tar.bz2
gentoo-3e26dd9088a0c10ba11063d0b6b8eaf61fa6b347.zip
app-emulation/fs-uae-launcher: Version bump to 3.1.26, EAPI 8
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/fs-uae-launcher/Manifest1
-rw-r--r--app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.26.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-emulation/fs-uae-launcher/Manifest b/app-emulation/fs-uae-launcher/Manifest
index 1513151a0767..72da28753327 100644
--- a/app-emulation/fs-uae-launcher/Manifest
+++ b/app-emulation/fs-uae-launcher/Manifest
@@ -1 +1,2 @@
DIST fs-uae-launcher-3.0.5.tar.gz 9633819 BLAKE2B 8ce627302244bbd7d174f28c0dad345699942429c1109a7408c88412f6bb0e3e5d765e6c51abf2b95837a83261023b4f9c58d65892e58043889be8dc5e4cb759 SHA512 1a6700c56a14edce86ffbefee7494117af067da8b1dbc22937a36641ccb90927a3bbb011d15a891388bf08378aa623e00a2d45dbc49e822a5a569e110843add5
+DIST fs-uae-launcher-3.1.26.tar.gz 9656516 BLAKE2B 1b8d12ef91631dedf412976e81529ac7138b7f688ad6ae1ad55bfd3625590ee00aab89d229d2aa64eec577d291a6e634362c557428534c355fdb39e878f40253 SHA512 0e4e542bebfe2d8f862005c016fe70319dd6c5e1e413be9b0ce0421bb95253ba6eb92337989cc86210094b9b02a6ad86da4725f1a65d50673703fa6c6cb58f37
diff --git a/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.26.ebuild b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.26.ebuild
new file mode 100644
index 000000000000..537313395f85
--- /dev/null
+++ b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.26.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="PyQt5-based launcher for FS-UAE"
+HOMEPAGE="https://fs-uae.net/"
+SRC_URI="https://github.com/FrodeSolheim/fs-uae-launcher/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="lha"
+RETRICT="test" # The test files are just boilerplate.
+
+RDEPEND="
+ app-emulation/fs-uae
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative,gui,network,opengl,widgets]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ lha? ( dev-python/python-lhafile[${PYTHON_USEDEP}] )
+ ')
+"
+
+BDEPEND="
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.0-ROMs.patch
+)
+
+src_prepare() {
+ default
+ python bootstrap
+
+ # Unbundle OpenGL library. Keep oyoyo IRC library because upstream
+ # is long dead and it's not worth packaging separately.
+ rm -r OpenGL/ || die
+ sed -i -r "/OpenGL/d" setup.py || die
+}
+
+python_compile_all() {
+ emake
+}
+
+python_install() {
+ local dir=${EPREFIX}/usr/share/${PN}
+ distutils-r1_python_install --install-lib="${dir}" --install-scripts="${dir}"
+}
+
+python_install_all() {
+ dosym ../share/${PN}/${PN} /usr/bin/${PN}
+ emake install-data DESTDIR="${D}" prefix="${EPREFIX}"/usr
+ mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
+}
+
+pkg_postinst() {
+ elog "Some important information:"
+ elog
+ ewarn " - Do not use QtCurve, it will crash PyQt5!"
+ elog
+ elog " - By default, FS-UAE creates its directories under Documents/FS-UAE."
+ elog " If your Documents directory is not configured according to the XDG"
+ elog " user diretory spec, ~/FS-UAE will be used as a fallback."
+ elog
+ elog " - You can override this by putting the path to the desired base"
+ elog " directory in a special config file. The config file will be read"
+ elog " from ~/.config/fs-uae/base-dir by both FS-UAE and FS-UAE Launcher"
+ elog " if it exists."
+ elog
+ elog " Alternatively, you can start FS-UAE and/or FS-UAE Launcher with"
+ elog " --base-dir=/path/to/desired/dir"
+}