summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-13 15:32:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-13 15:39:17 -0400
commit833cda0ebfeee6e493623e55a4ec94ece9bc9825 (patch)
tree1d56b4db07ae3bdcebba4ed6b855ca332dcc883f /app-emulation
parentdev-python/cattrs: Stabilize 23.1.2 x86, #912240 (diff)
downloadgentoo-833cda0ebfeee6e493623e55a4ec94ece9bc9825.tar.gz
gentoo-833cda0ebfeee6e493623e55a4ec94ece9bc9825.tar.bz2
gentoo-833cda0ebfeee6e493623e55a4ec94ece9bc9825.zip
app-emulation/wine-vanilla: adjust comments w/ bugref for clang
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild3
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild3
7 files changed, 9 insertions, 7 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
index eee523c84dde..ddff00b2ea43 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
@@ -178,7 +178,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
index aed49df3605b..fff16211ef70 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
@@ -176,7 +176,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
index ca24322d73fc..fb1ab81d78d7 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.0.2.ebuild
@@ -176,7 +176,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
index 9573a0a88c0b..ba2f5e2f4c08 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
@@ -180,7 +180,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild
index 9573a0a88c0b..ba2f5e2f4c08 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.12.ebuild
@@ -180,7 +180,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
index 8eec4853243e..3822698583f1 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
@@ -36,6 +36,7 @@ IUSE="
+truetype udev udisks +unwind usb v4l +vulkan wayland wow64
+xcomposite xinerama"
# bug #551124 for truetype
+# TODO: wow64 can be done without mingw if using clang (needs bug #912237)
REQUIRED_USE="
X? ( truetype )
crossdev-mingw? ( mingw )
@@ -192,7 +193,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 8eec4853243e..3822698583f1 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -36,6 +36,7 @@ IUSE="
+truetype udev udisks +unwind usb v4l +vulkan wayland wow64
+xcomposite xinerama"
# bug #551124 for truetype
+# TODO: wow64 can be done without mingw if using clang (needs bug #912237)
REQUIRED_USE="
X? ( truetype )
crossdev-mingw? ( mingw )
@@ -192,7 +193,7 @@ src_prepare() {
# drop as a quick fix for now which hopefully should be safe
sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
else
- # ./configure will abort looking for -mabi=ms, so do it early
+ # known broken due to bug #912237, require mingw for now
die "building ${PN} with clang requires USE=mingw to be enabled"
fi
fi