summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-28 07:59:38 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-28 08:13:36 -0400
commita6fc6d87eb829a9c6cfb837cc2f05b817987f127 (patch)
treeced76666550ad9de681dbd1897cd8a0b0ae599b3 /app-emulation
parentapp-emulation/wine-staging: warn if nvidia[abi_x86_32] is missing (diff)
downloadgentoo-a6fc6d87eb829a9c6cfb837cc2f05b817987f127.tar.gz
gentoo-a6fc6d87eb829a9c6cfb837cc2f05b817987f127.tar.bz2
gentoo-a6fc6d87eb829a9c6cfb837cc2f05b817987f127.zip
app-emulation/wine-proton: warn if nvidia[abi_x86_32] is missing
Hard to know for sure if it's really used or not, but do not want to introduce a kinda no-op VIDEO_CARDS on wine to actually depend on it over a warning. Less of an issue with mesa given other dependencies end up requiring it (technically the dep is wrong given e.g. nvidia would not need mesa[abi_x86_32], but well). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-proton/wine-proton-7.0.6.ebuild7
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.3c.ebuild7
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.9999.ebuild7
3 files changed, 21 insertions, 0 deletions
diff --git a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
index 2d64d08da94f..b0d8137fd450 100644
--- a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
+++ b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
@@ -336,6 +336,13 @@ pkg_preinst() {
pkg_postinst() {
[[ -v WINE_HAD_ANY_SLOT ]] || readme.gentoo_print_elog
+ if use abi_x86_32 && has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-proton/wine-proton-8.0.3c.ebuild b/app-emulation/wine-proton/wine-proton-8.0.3c.ebuild
index 28c682e79696..0a109f5bc674 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.3c.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.3c.ebuild
@@ -348,6 +348,13 @@ pkg_preinst() {
pkg_postinst() {
[[ -v WINE_HAD_ANY_SLOT ]] || readme.gentoo_print_elog
+ if use abi_x86_32 && has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
index 53ac9ce2e64b..16f19e3a308d 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
@@ -352,6 +352,13 @@ pkg_preinst() {
pkg_postinst() {
[[ -v WINE_HAD_ANY_SLOT ]] || readme.gentoo_print_elog
+ if use abi_x86_32 && has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
+ fi
+
eselect wine update --if-unset || die
}