summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-16 17:28:41 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-03-16 17:48:41 -0400
commitd36186d439051653a38568af44f8d2afa3fb2bf0 (patch)
tree80357c5408853c8d2650f3d95750052f3fca6b1d /app-emulation
parentsys-auth/skey: Fix length check in skeylogin.c (diff)
downloadgentoo-d36186d439051653a38568af44f8d2afa3fb2bf0.tar.gz
gentoo-d36186d439051653a38568af44f8d2afa3fb2bf0.tar.bz2
gentoo-d36186d439051653a38568af44f8d2afa3fb2bf0.zip
app-emulation/wine-vanilla: add IUSE=wayland in live
Not that should expect this to be useful yet, it's early work in progress. But the option exists so let's add it for anyone interested. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index f6281520f096..69a8a4af667a 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -30,8 +30,9 @@ IUSE="
+X +abi_x86_32 +abi_x86_64 +alsa capi crossdev-mingw cups dos
llvm-libunwind debug custom-cflags +fontconfig +gecko gphoto2
+gstreamer kerberos +mingw +mono netapi nls odbc opencl +opengl
- osmesa pcap perl pulseaudio samba scanner +sdl selinux smartcard +ssl
- +truetype udev udisks +unwind usb v4l +vulkan +xcomposite xinerama"
+ osmesa pcap perl pulseaudio samba scanner +sdl selinux smartcard
+ +ssl +truetype udev udisks +unwind usb v4l +vulkan wayland
+ +xcomposite xinerama"
REQUIRED_USE="
X? ( truetype )
crossdev-mingw? ( mingw )" # bug #551124 for truetype
@@ -91,7 +92,8 @@ WINE_COMMON_DEPEND="
llvm-libunwind? ( sys-libs/llvm-libunwind[${MULTILIB_USEDEP}] )
!llvm-libunwind? ( sys-libs/libunwind:=[${MULTILIB_USEDEP}] )
)
- usb? ( dev-libs/libusb:1[${MULTILIB_USEDEP}] )"
+ usb? ( dev-libs/libusb:1[${MULTILIB_USEDEP}] )
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )"
RDEPEND="
${WINE_COMMON_DEPEND}
app-emulation/wine-desktop-common
@@ -214,6 +216,7 @@ src_configure() {
$(use_with usb)
$(use_with v4l v4l2)
$(use_with vulkan)
+ $(use_with wayland)
$(use_with xcomposite)
$(use_with xinerama)
$(usev !odbc ac_cv_lib_soname_odbc=)