summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzesimir Nowak <knowak@microsoft.com>2024-05-24 17:08:25 +0200
committerSam James <sam@gentoo.org>2024-05-25 09:25:31 +0100
commitf127c4a6b2c7ca2584b2621ea0cd96b865a3bda3 (patch)
tree88689a7edb06f2a0897ffb4bffc9254b787644d7 /app-emulation
parenteclass/tests: Copy code from eapi7-ver.eclass to version-functions.sh (diff)
downloadgentoo-f127c4a6b2c7ca2584b2621ea0cd96b865a3bda3.tar.gz
gentoo-f127c4a6b2c7ca2584b2621ea0cd96b865a3bda3.tar.bz2
gentoo-f127c4a6b2c7ca2584b2621ea0cd96b865a3bda3.zip
app-emulation/qemu-guest-agent: Fix cross-compilation issue
The fix is borrowed from app-emulation/qemu. Passing cross-prefix is necessary to make meson do a cross-build, otherwise the build system will try to use intrinsics suitable for build machine instead of host machine, when building some crypto stuff. Signed-off-by: Krzesimir Nowak <knowak@microsoft.com> Closes: https://github.com/gentoo/gentoo/pull/36808 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild b/app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild
index 7426f9441f2a..3002f6df679d 100644
--- a/app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild
+++ b/app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild
@@ -52,6 +52,9 @@ src_configure() {
--host-cc="$(tc-getBUILD_CC)"
)
+ # Meson will not use a cross-file unless cross_prefix is set.
+ tc-is-cross-compiler && myconf+=( --cross-prefix="${CHOST}-" )
+
edo ./configure "${myconf[@]}"
}