summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-12-10 20:07:02 -0500
committerMichael Orlitzky <mjo@gentoo.org>2015-12-10 20:07:20 -0500
commit983c8fcbdf2b0cea1236c87ac84bf4874a916271 (patch)
tree650cf807ace73a9077930bcdcfd2a9a77250fbdb /app-eselect
parentapp-doc/doxygen: Update live ebuild to EAPI=5, change SRC_URI to github (diff)
downloadgentoo-983c8fcbdf2b0cea1236c87ac84bf4874a916271.tar.gz
gentoo-983c8fcbdf2b0cea1236c87ac84bf4874a916271.tar.bz2
gentoo-983c8fcbdf2b0cea1236c87ac84bf4874a916271.zip
app-eselect/eselect-php: version bump adding v0.8.1.
This is another attempt at php-7.x support in apache2. This new version is already masked for testing, which is good because it requires some configuration changes to apache. Upgraders should read the elogs. Gentoo-Bug: 552156 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-php/Manifest1
-rw-r--r--app-eselect/eselect-php/eselect-php-0.8.1.ebuild54
-rw-r--r--app-eselect/eselect-php/files/70_mod_php.conf26
3 files changed, 81 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/Manifest b/app-eselect/eselect-php/Manifest
index 9c9280e473ee..249fc20c0feb 100644
--- a/app-eselect/eselect-php/Manifest
+++ b/app-eselect/eselect-php/Manifest
@@ -1,2 +1,3 @@
DIST eselect-php-0.7.1.bz2 2251 SHA256 10aa400e2d08bc71989366993f12ddb546a0ea29f191c40e37beba1d11d7abd7 SHA512 a6b4c1475dda9f368d799db7658c50cef7d6f71482a53a186fb1394e7ea1fff3c0ef123c82b7ca4d1e45aadb0a034d36f213fc9450766878a60d28639761cb3d WHIRLPOOL a4e45492068616ff30fd888b0cc64441a6eb6e6656e0107d00bd2cf15360dce15052d4d62089ab89d43e6bb36e126529aa101c70e8bd94a9fc916a5369463e3b
DIST eselect-php-0.8.0.tar.xz 43932 SHA256 1ddc6aafe269ebbf3006737701403bd2c7b324b9eea0fcbdc91e85a856f8a10d SHA512 53c735275264742542d3909ae2994d0720bc961533a3df5373dbc7a7a1f04e91591f4e8356c268954420487d3ead4006cc5d6f361ef0ac2836f7f126556e960d WHIRLPOOL 94deba4a5bd4d0d85c8f3afc96ac30a69cca5db95014b2fd8701495cc83488389302f640065e923cabd40c95f97f792dd173337cc33c7d38441956049fb90cda
+DIST eselect-php-0.8.1.tar.xz 44412 SHA256 aa118e936bff176fe64911d68bb72e6e9e03d33c106674169396826a3063a962 SHA512 3679c8ac4d980424a108d93c8e2e575b93196d7140f31f900e7f925ab26cf821233d12b9083fd7bdd7bd596c3b59544e972660be8ffce7c24d4a7980fbe5f770 WHIRLPOOL 19c6f05a02aa1a40586f352822679f7e655200374a100834d4370678b35856d5e255b0d83f07eafd69481ee3ee72cb976665e6c2b2df990be00b54bfa53a5a92
diff --git a/app-eselect/eselect-php/eselect-php-0.8.1.ebuild b/app-eselect/eselect-php/eselect-php-0.8.1.ebuild
new file mode 100644
index 000000000000..d7a5283e275d
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit depend.apache systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )"
+
+want_apache
+
+src_install() {
+ default
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR#${EPREFIX}}"
+ doins "${FILESDIR}/70_mod_php.conf"
+ fi
+
+ if use fpm ; then
+ newinitd "${FILESDIR}/php-fpm.init-r4" "php-fpm"
+ systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/php-fpm-launcher"
+ fi
+}
+
+pkg_postinst() {
+ if use apache2 ; then
+ elog
+ elog "If you are upgrading, be warned that our mod_php configuration"
+ elog "file has changed! You should now define -DPHP for the apache2"
+ elog "daemon, and inspect the new 70_mod_php.conf which has been"
+ elog "installed. Module loading involves eselect as of this version."
+ elog
+ elog "You must run eselect at least once to choose your apache2 target"
+ elog "before the new configuration will work. Afterwards, and after you"
+ elog "have reviewed your new configuration, you are advised to remove"
+ elog "the obsolete 70_mod_php5.conf file."
+ elog
+ fi
+}
diff --git a/app-eselect/eselect-php/files/70_mod_php.conf b/app-eselect/eselect-php/files/70_mod_php.conf
new file mode 100644
index 000000000000..cf996fab3cf8
--- /dev/null
+++ b/app-eselect/eselect-php/files/70_mod_php.conf
@@ -0,0 +1,26 @@
+<IfDefine PHP>
+ # The mod_php.so symlink is controlled by
+ # eselect-php. However, the module name changed from
+ # php5_module to php7_module so we can't blindly load whatever
+ # is there. Instead we let eselect-php manage a small
+ # configuration file that loads the appropriate module.
+ #
+ # This is relative to ServerRoot (see httpd.conf).
+ Include ../../../var/lib/eselect-php/mod_php.conf
+
+ # Tell apache that mod_php should handle PHP files.
+ #
+ # NOTE: Avoiding AddHandler/AddType for security (bug
+ # #538822). Please read the related news item!
+ <FilesMatch "\.(php|php[57]|phtml)$">
+ SetHandler application/x-httpd-php
+ </FilesMatch>
+
+ # PHP source files which are meant to be displayed as
+ # syntax-highlighted source code.
+ <FilesMatch "\.phps$">
+ SetHandler application/x-httpd-php-source
+ </FilesMatch>
+
+ DirectoryIndex index.php index.phtml
+</IfDefine>