summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-08-09 22:56:26 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-08-09 22:56:26 +0900
commit0cb5ff47ed38778ff979a6cebcbb8590f040fdce (patch)
tree5e40a76527ffacfb1907f54c39e6caa75ff6c75d /app-i18n/ibus-typing-booster
parentmedia-tv/mythtv: Fixed detection of >=qt-5.10 (diff)
downloadgentoo-0cb5ff47ed38778ff979a6cebcbb8590f040fdce.tar.gz
gentoo-0cb5ff47ed38778ff979a6cebcbb8590f040fdce.tar.bz2
gentoo-0cb5ff47ed38778ff979a6cebcbb8590f040fdce.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 71a9e3006f67..bba7d9f28325 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-1.5.38.tar.gz 6408096 BLAKE2B a4559044a4cd06c5dcf69d77d5ec3d8163d564702ff88d3ed11b8c073f5272e2cfab446de548a29887b74767f4318db98fb898dc4d15488fd4c9963cea151009 SHA512 67b81a47501ae4e885d2a79b122799b78dcdd044ad8e36a140d4c6587a23072d08e3e025f755c191cee82c3ab81ea1a974a5a0f6438e7203ba2d63d7e1cd4eff
DIST ibus-typing-booster-2.0.0.tar.gz 5689495 BLAKE2B a3ee39faf206c4681d10989d4e438cffc0b78d9339973523af61310482b3ec13c7935e9e49403a3359e0f32d087b72afb27ae7975dcd3abd427b9a0f5f0ba581 SHA512 140044be13b47590a0835bb4b8da7311cdb92e8134a88a7b999ea6f530298950c4f8ce9ff3462394e4b52de0c56e3072671da85c99b448a91f442fdc460c608b
+DIST ibus-typing-booster-2.1.0.tar.gz 6054311 BLAKE2B c0eef436e89e1de56d47713b2c5685d15cddc08d744926b69e6d0d1d7bd7548614009f489d6ae2579482d4d770b62e51cc76734ab3866451ec4fd4d51c84d59b SHA512 7d1b8d0761bdd71a3c72a60d59e0f7f1c94c8c8863b2a1cfb4ed7742060482500d43d7f71bc328a50628a9c116297695813651d7712b88cf7e8594118c4b339f
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.1.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.1.0.ebuild
new file mode 100644
index 000000000000..b4bb8048b30d
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"