summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-08-02 16:30:44 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-08-19 15:51:08 +0300
commit369833578fc4b514a146bbed749ed24efdac851b (patch)
treecaa34f902c2640f43aee1a45737580b9168fbbda /app-i18n/mecab-skkserv
parentapp-laptop/mbpfan: Fix call to undeclared function vsyslog (diff)
downloadgentoo-369833578fc4b514a146bbed749ed24efdac851b.tar.gz
gentoo-369833578fc4b514a146bbed749ed24efdac851b.tar.bz2
gentoo-369833578fc4b514a146bbed749ed24efdac851b.zip
app-i18n/mecab-skkserv: Fix call to undeclared library function strcmp
and update EAPI 6 -> 8 Closes: https://bugs.gentoo.org/894518 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32145 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-i18n/mecab-skkserv')
-rw-r--r--app-i18n/mecab-skkserv/files/mecab-skkserv-missing-strcmp-clang16.patch11
-rw-r--r--app-i18n/mecab-skkserv/mecab-skkserv-0.03-r1.ebuild42
2 files changed, 53 insertions, 0 deletions
diff --git a/app-i18n/mecab-skkserv/files/mecab-skkserv-missing-strcmp-clang16.patch b/app-i18n/mecab-skkserv/files/mecab-skkserv-missing-strcmp-clang16.patch
new file mode 100644
index 000000000000..dee8284c8d8e
--- /dev/null
+++ b/app-i18n/mecab-skkserv/files/mecab-skkserv-missing-strcmp-clang16.patch
@@ -0,0 +1,11 @@
+Closes: https://bugs.gentoo.org/894518
+--- a/getopt.c
++++ b/getopt.c
+@@ -40,6 +40,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h>
+
+ /* Comment out all this code if we are using the GNU C Library, and are not
+ actually compiling the library itself. This code is part of the GNU C
diff --git a/app-i18n/mecab-skkserv/mecab-skkserv-0.03-r1.ebuild b/app-i18n/mecab-skkserv/mecab-skkserv-0.03-r1.ebuild
new file mode 100644
index 000000000000..7bb86ee64ec9
--- /dev/null
+++ b/app-i18n/mecab-skkserv/mecab-skkserv-0.03-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools
+
+DESCRIPTION="mecab-skkserv is a Kana-Kanji conversion server using MeCab"
+HOMEPAGE="http://chasen.org/~taku/software/mecab-skkserv/"
+SRC_URI="http://chasen.org/~taku/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 ipadic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/mecab"
+RDEPEND="${DEPEND}
+ sys-apps/xinetd"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-cflags.patch
+ "${FILESDIR}"/${PN}-dicrc.patch
+ "${FILESDIR}"/${PN}-getopt.patch
+ "${FILESDIR}"/${PN}-missing-strcmp-clang16.patch
+)
+HTML_DOCS=( index.html ${PN}.css )
+
+src_prepare() {
+ sed -i "/^dictdir/s:lib:$(get_libdir):" Makefile.am
+
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/${PN}.xinetd ${PN}
+}