summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornilburn <nilburn+gentoo-bugs@gmail.com>2015-08-26 07:03:15 +0000
committerAkinori Hattori <hattya@gentoo.org>2018-07-31 21:31:54 +0900
commit1348200690ff829d9e909c71bf30375b19461472 (patch)
tree1b64a2aeffbfaab2a3290b040cce5b3aff40fa16 /app-i18n/nkf/nkf-2.1.3-r2.ebuild
parentapp-i18n/nkf: update to EAPI 6 (diff)
downloadgentoo-1348200690ff829d9e909c71bf30375b19461472.tar.gz
gentoo-1348200690ff829d9e909c71bf30375b19461472.tar.bz2
gentoo-1348200690ff829d9e909c71bf30375b19461472.zip
app-i18n/nkf: fix install with USE=perl
Closes: https://bugs.gentoo.org/558784 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-i18n/nkf/nkf-2.1.3-r2.ebuild')
-rw-r--r--app-i18n/nkf/nkf-2.1.3-r2.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/app-i18n/nkf/nkf-2.1.3-r2.ebuild b/app-i18n/nkf/nkf-2.1.3-r2.ebuild
new file mode 100644
index 000000000000..21daf284bc4f
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.1.3-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 perl-module toolchain-funcs
+
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="mirror://sourceforge.jp/${PN}/59912/${P}.tar.gz
+ l10n_ja? ( https://dev.gentoo.org/~naota/files/${PN}.1j )
+ python? ( https://dev.gentoo.org/~naota/files/NKF_python20090602.tgz )"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-macos"
+IUSE="perl python l10n_ja"
+
+src_prepare() {
+ sed -i \
+ -e "/^CFLAGS/{ s/-g -O2//; s/=/+=/; }" \
+ -e "/ -o ${PN}/s/\(-o \)/\$(LDFLAGS) \1/" \
+ Makefile
+ if use l10n_ja; then
+ cp "${DISTDIR}"/${PN}.1j ${PN}.ja.1 || die
+ fi
+ if use python; then
+ mv "${WORKDIR}"/NKF.python . || die
+ eapply "${FILESDIR}"/${P}-strip.patch
+ fi
+
+ default
+}
+
+src_configure() {
+ default
+ if use perl; then
+ cd NKF.mod
+ perl-module_src_configure
+ cd - >/dev/null
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+ if use perl; then
+ cd NKF.mod
+ perl-module_src_compile
+ cd - >/dev/null
+ fi
+ if use python; then
+ cd NKF.python
+ distutils-r1_src_compile
+ cd - >/dev/null
+ fi
+}
+
+src_test() {
+ default
+ if use perl; then
+ cd NKF.mod
+ perl-module_src_test
+ cd - >/dev/null
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+
+ if use l10n_ja; then
+ doman ${PN}.ja.1
+ fi
+ dodoc ${PN}.doc
+
+ if use perl; then
+ cd NKF.mod
+ docinto perl
+ perl-module_src_install
+ cd - >/dev/null
+ fi
+ if use python; then
+ cd NKF.python
+ docinto python
+ DOCS= distutils-r1_src_install
+ dodoc README
+ cd - >/dev/null
+ fi
+}