summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-18 14:53:27 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-18 14:53:27 +0200
commit4b18bb8e01438a52147cb94e94085bf753fdefd3 (patch)
treeeef27c38e7c886aba9a340ed199bf79631f654e3 /app-i18n
parentmedia-video/aegisub: [QA] Fix leading whitespace (diff)
downloadgentoo-4b18bb8e01438a52147cb94e94085bf753fdefd3.tar.gz
gentoo-4b18bb8e01438a52147cb94e94085bf753fdefd3.tar.bz2
gentoo-4b18bb8e01438a52147cb94e94085bf753fdefd3.zip
app-i18n/kcc: Port to EAPI 7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/kcc/Manifest2
-rw-r--r--app-i18n/kcc/files/kcc-1.0-fix-build-system.patch24
-rw-r--r--app-i18n/kcc/kcc-1.0.ebuild29
3 files changed, 39 insertions, 16 deletions
diff --git a/app-i18n/kcc/Manifest b/app-i18n/kcc/Manifest
index e18b6624212f..5bd0c964e301 100644
--- a/app-i18n/kcc/Manifest
+++ b/app-i18n/kcc/Manifest
@@ -1 +1 @@
-DIST kcc.tar.gz 18869 BLAKE2B 122e6e749a0cc6a63244d32d735a23ea3bdc6ce81e90674d4aa8c6460b57c631e504490454710601a3e057c413d5579495533320f37820d4c3afd9053325c1dc SHA512 2ec1645bb7edbe49c6845cd6e6794568bd48efec367d2d9628ddb8a72d2b5edd590be101f4d9c8856764ae85c9aad7b0adf69601b78fddffdc23235b96f65145
+DIST kcc-1.0.tar.gz 18869 BLAKE2B 122e6e749a0cc6a63244d32d735a23ea3bdc6ce81e90674d4aa8c6460b57c631e504490454710601a3e057c413d5579495533320f37820d4c3afd9053325c1dc SHA512 2ec1645bb7edbe49c6845cd6e6794568bd48efec367d2d9628ddb8a72d2b5edd590be101f4d9c8856764ae85c9aad7b0adf69601b78fddffdc23235b96f65145
diff --git a/app-i18n/kcc/files/kcc-1.0-fix-build-system.patch b/app-i18n/kcc/files/kcc-1.0-fix-build-system.patch
new file mode 100644
index 000000000000..7818215d62fc
--- /dev/null
+++ b/app-i18n/kcc/files/kcc-1.0-fix-build-system.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -10,11 +10,9 @@
+ BINPATH = /usr/local/bin
+ MANPATH = /usr/local/man
+ JMANDIR = japanese
+- CFLAGS = -O
+
+ SHELL = /bin/sh
+ CP = cp
+- MAKE = make
+ INSTALL = install
+
+ CMDS = kcc
+@@ -23,9 +21,6 @@
+
+ all: kcc
+
+-kcc: kcc.o
+- $(CC) $(CFLAGS) -o kcc kcc.o
+-
+ install: $(BINPATH)/kcc
+ @echo "\`make install' done."
+ @echo "Run \`make install.man' to install a manual."
diff --git a/app-i18n/kcc/kcc-1.0.ebuild b/app-i18n/kcc/kcc-1.0.ebuild
index bcb220713949..20ee1ee57350 100644
--- a/app-i18n/kcc/kcc-1.0.ebuild
+++ b/app-i18n/kcc/kcc-1.0.ebuild
@@ -1,34 +1,33 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A Kanji code converter"
HOMEPAGE="http://www2s.biglobe.ne.jp/~Nori/ruby/"
-SRC_URI="ftp://ftp.jp.freebsd.org/pub/FreeBSD/ports/distfiles/${PN}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE=""
S="${WORKDIR}/${PN}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-gcc3-gentoo.diff"
- epatch "${FILESDIR}/${PN}-exit.diff"
- sed -i "s:\(-o kcc\):\$(LDFLAGS) \1:" Makefile
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc3-gentoo.diff
+ "${FILESDIR}"/${PN}-exit.diff
+ "${FILESDIR}"/${PN}-1.0-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
}
src_install() {
dobin kcc
- dodoc README
+ einstalldocs
+
cp -f kcc.jman kcc.1 || die
doman -i18n=ja kcc.1
}