summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2018-04-04 09:33:38 +0200
committerChristoph Junghans <junghans@gentoo.org>2018-06-10 12:17:12 -0600
commit99cc1546b234910e0c1ef671e2449c68815687fe (patch)
treeffe2eefc3280a38d39e81b2916dd27994d6c7be3 /app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild
parentdev-perl/Sereal-Encoder: stable 4.4.0 for ia64, bug #657574 (diff)
downloadgentoo-99cc1546b234910e0c1ef671e2449c68815687fe.tar.gz
gentoo-99cc1546b234910e0c1ef671e2449c68815687fe.tar.bz2
gentoo-99cc1546b234910e0c1ef671e2449c68815687fe.zip
app-laptop/tpacpi-bat: bump to version 3.1
Bug: https://github.com/gentoo/gentoo/pull/7803 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Signed-off-by: Henning Schild <henning@hennsch.de>
Diffstat (limited to 'app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild')
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild
new file mode 100644
index 000000000000..6364a4ee745f
--- /dev/null
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/teleshoes/tpacpi-bat.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+DESCRIPTION="Control battery thresholds of recent ThinkPads, not supported by tp_smapi"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-power/acpi_call
+ dev-lang/perl"
+
+src_install() {
+ dodoc README.md battery_asl
+ dobin tpacpi-bat
+ newinitd "${FILESDIR}"/${PN}.initd.2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd.1 ${PN}
+ systemd_newunit examples/systemd_fixed_threshold/tpacpi.service \
+ ${PN}.service
+}