summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/cw/cw-1.0.16-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/cw/cw-1.0.16-r3.ebuild')
-rw-r--r--app-misc/cw/cw-1.0.16-r3.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-misc/cw/cw-1.0.16-r3.ebuild b/app-misc/cw/cw-1.0.16-r3.ebuild
new file mode 100644
index 000000000000..c032948da274
--- /dev/null
+++ b/app-misc/cw/cw-1.0.16-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A non-intrusive real-time ANSI color wrapper for common unix-based commands"
+HOMEPAGE="http://cwrapper.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cwrapper/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-path.patch \
+ "${FILESDIR}"/${PV}-collision.patch \
+ "${FILESDIR}"/${PV}-format-security.patch
+ tc-export CC
+}
+
+src_compile() {
+ emake local
+}
+
+src_install() {
+ insinto /usr/share/cw
+ doins etc/*
+
+ exeinto /usr/libexec/cw
+ doexe def/*
+
+ doman man/cwu*
+ newman man/cw.* color-wrapper
+ dodoc CHANGES CONTRIB INSTALL README PLATFORM doc/README*
+
+ dobin bin/{cwu,colorcfg}
+ # app-misc/color currently conflicts; hopefully 'colors' is safe
+ newbin bin/color colors
+ # media-radio/unixcw currently conflicts;
+ newbin bin/cw color-wrapper
+}
+
+pkg_postinst() {
+ ebegin "Updating definition files"
+ cwu /usr/libexec/cw /usr/bin/color-wrapper # >/dev/null
+ eend $?
+
+ elog "To enable color-wrapper, as your user, run:"
+ elog " colorcfg [1|2|3]"
+ elog "to add relevant environment variables to your ~/.bash_profile"
+ elog "Run colorcfg without options to see what [1|2|3] means."
+ elog
+ elog "After sourcing your ~/.bash_profile, commands for which definitions"
+ elog "are provided should have colored output."
+ elog
+ elog "To enable/disable colored output, run: 'colors [on|off]'."
+}