summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-16 15:33:13 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-24 10:36:47 +0100
commite065922601acf708006c45e22961ff01c67131c2 (patch)
treeb268cbbafd38b41505c7cf60bd6f48068e152844 /app-misc/ddcui/files
parentapp-misc/ddcutil: add 2.0.0 (diff)
downloadgentoo-e065922601acf708006c45e22961ff01c67131c2.tar.gz
gentoo-e065922601acf708006c45e22961ff01c67131c2.tar.bz2
gentoo-e065922601acf708006c45e22961ff01c67131c2.zip
app-misc/ddcui: add 0.4.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/33847 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-misc/ddcui/files')
-rw-r--r--app-misc/ddcui/files/ddcui-0.4.2-drop-qthelp-dep.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/ddcui/files/ddcui-0.4.2-drop-qthelp-dep.patch b/app-misc/ddcui/files/ddcui-0.4.2-drop-qthelp-dep.patch
new file mode 100644
index 000000000000..d7552b323ba1
--- /dev/null
+++ b/app-misc/ddcui/files/ddcui-0.4.2-drop-qthelp-dep.patch
@@ -0,0 +1,30 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aa68d60..522c9f3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -98,12 +98,11 @@ message( ${VERBOSE} " CMAKE_AUTORCC: ${CMAKE_AUTORCC}")
+
+ set(QT5_LIBRARIES Qt5::Widgets )
+ # Ensures all Qt componenets have same version:
+-find_package(Qt5 ${ddcui_qt_version} COMPONENTS Core Widgets Gui Help REQUIRED)
++find_package(Qt5 ${ddcui_qt_version} COMPONENTS Core Widgets Gui REQUIRED)
+ message( ${VERBOSE} "Qt directories:")
+ message( ${VERBOSE} " Qt5Widgets_INCLUDE_DIRS: ${Qt5Widgets_INCLUDE_DIRS}" )
+ message( ${VERBOSE} " Qt5Core_INCLUDE_DIRS: ${Qt5Core_INCLUDE_DIRS}" )
+ message( ${VERBOSE} " Qt5Gui_INCLUDE_DIRS: ${Qt5Gui_INCLUDE_DIRS}" )
+-message( ${VERBOSE} " Qt5Help_INCLUDE_DIRS: ${Qt5Help_INCLUDE_DIRS}" )
+
+ find_package (PkgConfig REQUIRED )
+ pkg_check_modules(GLIB2 REQUIRED glib-2.0>=${ddcui_glib_version})
+@@ -239,9 +238,9 @@ target_compile_options(ddcui PUBLIC "-fPIC" ${coverity_cflags})
+ # add_compile_options(-Og -H V=1)
+
+ # redundant: ${Qt5Gui_INCLUDE_DIRS} ${Qt5Core_INCLUDE_DIRS} ${Qt5Widgets_INCLUDE_DIRS}.
+-# ${Qt5Help_INCLUDE_DIRS} is a superset of them all
+ target_include_directories(ddcui SYSTEM PRIVATE
+- ${Qt5Help_INCLUDE_DIRS}
++ ${Qt5Gui_INCLUDE_DIRS}
++ ${Qt5Widgets_INCLUDE_DIRS}
+ ${GLIB2_INCLUDE_DIRS}
+ ${DDCUTIL_INCLUDE_DIRS})
+