summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-02-12 10:50:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-02-12 10:50:59 +0100
commit06352707b330a6092113a0fcd213cfaf386a1e71 (patch)
treedc046fd9e4a9bd77efd38c3d4eebc818a5b68261 /app-misc/detox/detox-1.4.0.ebuild
parentwww-misc/vdradmin-am: switch tmpfiles handling to tmpfiles.eclass (diff)
downloadgentoo-06352707b330a6092113a0fcd213cfaf386a1e71.tar.gz
gentoo-06352707b330a6092113a0fcd213cfaf386a1e71.tar.bz2
gentoo-06352707b330a6092113a0fcd213cfaf386a1e71.zip
app-misc/detox: Bump to version 1.4.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-misc/detox/detox-1.4.0.ebuild')
-rw-r--r--app-misc/detox/detox-1.4.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/detox/detox-1.4.0.ebuild b/app-misc/detox/detox-1.4.0.ebuild
new file mode 100644
index 000000000000..ab367fc95870
--- /dev/null
+++ b/app-misc/detox/detox-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Safely remove spaces and strange characters from filenames"
+HOMEPAGE="http://detox.sourceforge.net/ https://github.com/dharple/detox"
+SRC_URI="https://github.com/dharple/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+RDEPEND="
+ !dev-python/detox"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+"
+
+src_prepare() {
+ default
+ sed \
+ -e '/detoxrc.sample/d' \
+ -i Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc etc/${PN}rc.sample
+}