summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-10-27 14:47:45 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-10-27 14:47:45 -0700
commit073f42bd9abeb9d4870a74fcc612d1b3ed96dd7c (patch)
tree06fe5e5e5f92c150f018ab5d1def56d1f2f39543 /app-misc/icdiff/icdiff-1.9.1.ebuild
parentdev-python/twisted-conch: support dev-python/pycryptodome. (diff)
downloadgentoo-073f42bd9abeb9d4870a74fcc612d1b3ed96dd7c.tar.gz
gentoo-073f42bd9abeb9d4870a74fcc612d1b3ed96dd7c.tar.bz2
gentoo-073f42bd9abeb9d4870a74fcc612d1b3ed96dd7c.zip
app-misc/icdiff: Version bump to 1.9.1 (bug #619834)
Closes: https://bugs.gentoo.org/619834 Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'app-misc/icdiff/icdiff-1.9.1.ebuild')
-rw-r--r--app-misc/icdiff/icdiff-1.9.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-misc/icdiff/icdiff-1.9.1.ebuild b/app-misc/icdiff/icdiff-1.9.1.ebuild
new file mode 100644
index 000000000000..eda476f4a614
--- /dev/null
+++ b/app-misc/icdiff/icdiff-1.9.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python2_7 python3_4 python3_5)
+
+inherit distutils-r1
+
+DESCRIPTION="Colourized diff that supports side-by-side diffing"
+HOMEPAGE="http://www.jefftk.com/icdiff"
+SRC_URI="https://github.com/jeffkaufman/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=(README.md ChangeLog)
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+python_test() {
+ ./test.sh "${EPYTHON%.*}" || die "Tests failed"
+}