summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2022-01-11 21:48:11 +0000
committerPatrick McLean <chutzpah@gentoo.org>2022-01-11 14:15:52 -0800
commit257c8ada2bcb432dd034036678e24b83869f5c46 (patch)
treefa2c34dce679e99a9e2fa3c02be08495180d53d0 /app-misc/openrgb-plugin-skin
parentapp-misc/openrgb-plugin-effects: update to openrgb 0.7 (diff)
downloadgentoo-257c8ada2bcb432dd034036678e24b83869f5c46.tar.gz
gentoo-257c8ada2bcb432dd034036678e24b83869f5c46.tar.bz2
gentoo-257c8ada2bcb432dd034036678e24b83869f5c46.zip
app-misc/openrgb-plugin-skin: update to openrgb 0.7
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/openrgb-plugin-skin')
-rw-r--r--app-misc/openrgb-plugin-skin/Manifest1
-rw-r--r--app-misc/openrgb-plugin-skin/metadata.xml2
-rw-r--r--app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0_p20211230.ebuild44
3 files changed, 46 insertions, 1 deletions
diff --git a/app-misc/openrgb-plugin-skin/Manifest b/app-misc/openrgb-plugin-skin/Manifest
index 7e97f83b58c1..8e078750a974 100644
--- a/app-misc/openrgb-plugin-skin/Manifest
+++ b/app-misc/openrgb-plugin-skin/Manifest
@@ -1 +1,2 @@
DIST openrgbskinplugin-3d937cf5112a98052f98a106dc0f5de1eafc20ea.tar.bz2 14673 BLAKE2B e9ba7e072882a995d9d37274e612f0ad404c369bafb4e59db379f43242873f08f36adc5521277c2bac4e730c35cde561e535e30e5a37155bfe0fa408d5ba3b45 SHA512 1a23b843230da6778079873949e72280efe46c6c015eb27456283bae5d88b539d8a5f69e6f1580400e1cfa746bcd36b6a1ae597f510b0c331d16f56b6ae28670
+DIST openrgbskinplugin-ebb80f7bd0e1efaa995f60454f3c049a4607bc3b.tar.bz2 22843 BLAKE2B 30c88b143b3df829c543744b20424df24bde9dda10f770fb78d653609111801a4d1d3fe16ed3e3c15ad953f41113db5d4da40bc66f7ec57418b2e934cd9a2e32 SHA512 a70c0157072b6b638a5a4f3f48f41c73f422d0ac356174479901cd3d088faf6fe96e594b2a39b15de305e0355fd0d252dafc4a30b9216d57058ad2cde7f5a3e3
diff --git a/app-misc/openrgb-plugin-skin/metadata.xml b/app-misc/openrgb-plugin-skin/metadata.xml
index 4c8060bdf70c..4f1ad006ed77 100644
--- a/app-misc/openrgb-plugin-skin/metadata.xml
+++ b/app-misc/openrgb-plugin-skin/metadata.xml
@@ -10,6 +10,6 @@
<name>Alexey Sokolov</name>
</maintainer>
<upstream>
- <remote-id type="gitlab">OpenRGBDevelopers/openrgbskinplugin</remote-id>
+ <remote-id type="gitlab">OpenRGBDevelopers/OpenRGBSkinPlugin</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0_p20211230.ebuild b/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0_p20211230.ebuild
new file mode 100644
index 000000000000..16fd02edcd94
--- /dev/null
+++ b/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0_p20211230.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+MY_GIT_COMMIT="ebb80f7bd0e1efaa995f60454f3c049a4607bc3b"
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/openrgbskinplugin/-/archive/${MY_GIT_COMMIT}/openrgbskinplugin-${MY_GIT_COMMIT}.tar.bz2"
+S="${WORKDIR}/OpenRGBSkinPlugin-${MY_GIT_COMMIT}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Plugin for OpenRGB that allows you to customize the look and feel of OpenRGB"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBSkinPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.7:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBSkinPlugin.so.1.0.0
+}