summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /app-misc/sphinx/sphinx-2.2.11-r1.ebuild
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/sphinx/sphinx-2.2.11-r1.ebuild')
-rw-r--r--app-misc/sphinx/sphinx-2.2.11-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-misc/sphinx/sphinx-2.2.11-r1.ebuild b/app-misc/sphinx/sphinx-2.2.11-r1.ebuild
index b3133ba92eb8..5f45a59d12a7 100644
--- a/app-misc/sphinx/sphinx-2.2.11-r1.ebuild
+++ b/app-misc/sphinx/sphinx-2.2.11-r1.ebuild
@@ -87,9 +87,9 @@ src_configure() {
}
src_compile() {
- emake AR="$(tc-getAR)" || die "emake failed"
+ emake AR="$(tc-getAR)"
- emake -j 1 -C api/libsphinxclient || die "emake libsphinxclient failed"
+ emake -j 1 -C api/libsphinxclient
}
src_test() {
@@ -99,8 +99,8 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- emake DESTDIR="${D}" -C api/libsphinxclient install || die "install libsphinxclient failed"
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" -C api/libsphinxclient install
dodoc doc/*