summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-10-01 14:29:52 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-10-01 15:21:39 -0500
commitd6faeb93a9fd12841e72541af5fde5be7887be38 (patch)
tree24ae6f4aaa5ee7be98bd59849023e5adbe0f563b /app-misc/wally-cli/wally-cli-2.0.1.ebuild
parentnet-im/synapse: Stabilize 1.66.0 amd64, #873811 (diff)
downloadgentoo-d6faeb93a9fd12841e72541af5fde5be7887be38.tar.gz
gentoo-d6faeb93a9fd12841e72541af5fde5be7887be38.tar.bz2
gentoo-d6faeb93a9fd12841e72541af5fde5be7887be38.zip
app-misc/wally-cli: new package, add 2.0.1
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-misc/wally-cli/wally-cli-2.0.1.ebuild')
-rw-r--r--app-misc/wally-cli/wally-cli-2.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/wally-cli/wally-cli-2.0.1.ebuild b/app-misc/wally-cli/wally-cli-2.0.1.ebuild
new file mode 100644
index 000000000000..d87dcb360f59
--- /dev/null
+++ b/app-misc/wally-cli/wally-cli-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Flash your ZSA Keyboard the EZ way"
+HOMEPAGE="https://github.com/zsa/wally-cli"
+SRC_URI="https://github.com/zsa/${PN}/archive/refs/tags/${PV}-linux.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~ajak/dist/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+S="${WORKDIR}/${P}-linux"
+
+LICENSE="Apache-2.0 BSD BSD-4 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md license.md )
+
+src_compile() {
+ go build
+}
+
+src_install() {
+ default
+ dobin wally-cli
+}