summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2020-03-29 16:40:05 -0700
committerJoonas Niilola <juippis@gentoo.org>2020-04-05 10:17:56 +0300
commit132ac56787eafa08d11dd45432493f91ce44d1fa (patch)
tree2c959c86a523e7bbb99462fb5618b0951e213459 /app-misc
parentapp-misc/trash-cli: Drop old stable 0.12.9.14-r2 (diff)
downloadgentoo-132ac56787eafa08d11dd45432493f91ce44d1fa.tar.gz
gentoo-132ac56787eafa08d11dd45432493f91ce44d1fa.tar.bz2
gentoo-132ac56787eafa08d11dd45432493f91ce44d1fa.zip
app-misc/trash-cli: Fix DISTUTILS_USE_SETUPTOOLS QA notice
Also update to EAPI7, drop Python2 support, enable Python3.{7,8} Closes: https://bugs.gentoo.org/709952 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://github.com/gentoo/gentoo/pull/15165 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/trash-cli/trash-cli-0.17.1.14_p20170816-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/trash-cli/trash-cli-0.17.1.14_p20170816-r1.ebuild b/app-misc/trash-cli/trash-cli-0.17.1.14_p20170816-r1.ebuild
new file mode 100644
index 000000000000..4fd6cf1969c6
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.17.1.14_p20170816-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+GIT_REF=5abecd53e1d84f2a5fd3fc60d2f5d71e518826c5
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${GIT_REF}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${PN}-${GIT_REF}"
+
+DEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose