summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-25 04:04:08 +0100
committerSam James <sam@gentoo.org>2021-07-31 01:16:43 +0100
commitcca5e801c584f5a50a60d8c86ebe72feb35cad9f (patch)
tree2fc7f5cd09da6b0ee1bd33743c5a0327568b002e /app-misc
parentapp-misc/khal: [QA] unconditionally install completion files (diff)
downloadgentoo-cca5e801c584f5a50a60d8c86ebe72feb35cad9f.tar.gz
gentoo-cca5e801c584f5a50a60d8c86ebe72feb35cad9f.tar.bz2
gentoo-cca5e801c584f5a50a60d8c86ebe72feb35cad9f.zip
app-misc/khard: [QA] unconditionally install completion files
QA policy [0] says that we don't conditionalise installation of small files. It's a wasteful rebuild and inconsistent across packages for when users desire completions to be available. [0] https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0301 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/khard/khard-0.13.0-r1.ebuild (renamed from app-misc/khard/khard-0.13.0.ebuild)26
-rw-r--r--app-misc/khard/khard-0.17.0-r1.ebuild (renamed from app-misc/khard/khard-0.17.0.ebuild)25
2 files changed, 23 insertions, 28 deletions
diff --git a/app-misc/khard/khard-0.13.0.ebuild b/app-misc/khard/khard-0.13.0-r1.ebuild
index 7b7ff564f1b5..06a157e5b7f4 100644
--- a/app-misc/khard/khard-0.13.0.ebuild
+++ b/app-misc/khard/khard-0.13.0-r1.ebuild
@@ -1,20 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-
+PYTHON_COMPAT=( python3_8 )
DISTUTILS_USE_SETUPTOOLS=rdepend
-
inherit distutils-r1
DESCRIPTION="Console CardDAV client"
HOMEPAGE="https://github.com/scheibler/khard"
-LICENSE="GPL-3"
+LICENSE="GPL-3"
SLOT="0"
-IUSE="test zsh-completion"
+IUSE="test"
RESTRICT="!test? ( test )"
if [ "${PV}" == "9999" ]; then
@@ -32,7 +30,7 @@ RDEPEND="
dev-python/unidecode[${PYTHON_USEDEP}]
>dev-python/vobject-0.9.3[${PYTHON_USEDEP}]
"
-DEPEND="
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
@@ -44,15 +42,13 @@ DEPEND="
DOCS=( AUTHORS CHANGES README.md misc/khard/khard.conf.example )
+python_test() {
+ esetup.py test
+}
+
src_install() {
distutils-r1_src_install
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins misc/zsh/_khard
- fi
-}
-
-python_test() {
- esetup.py test
+ insinto /usr/share/zsh/site-functions
+ doins misc/zsh/_khard
}
diff --git a/app-misc/khard/khard-0.17.0.ebuild b/app-misc/khard/khard-0.17.0-r1.ebuild
index 3d491af83fd6..79c4e3cd1a71 100644
--- a/app-misc/khard/khard-0.17.0.ebuild
+++ b/app-misc/khard/khard-0.17.0-r1.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="Console CardDAV client"
HOMEPAGE="https://github.com/scheibler/khard"
+
LICENSE="GPL-3"
SLOT="0"
-IUSE="test zsh-completion"
+IUSE="test"
RESTRICT="!test? ( test )"
if [[ "${PV}" == *9999 ]]; then
@@ -30,7 +31,7 @@ RDEPEND="
dev-python/unidecode[${PYTHON_USEDEP}]
dev-python/vobject[${PYTHON_USEDEP}]
"
-DEPEND="
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
@@ -40,15 +41,13 @@ DEPEND="
DOCS=( CHANGES CONTRIBUTING.rst README.md doc/source/examples/khard.conf.example )
+python_test() {
+ esetup.py test
+}
+
src_install() {
distutils-r1_src_install
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins misc/zsh/_khard
- fi
-}
-
-python_test() {
- esetup.py test
+ insinto /usr/share/zsh/site-functions
+ doins misc/zsh/_khard
}