summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-07-09 10:02:01 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-07-09 10:09:27 +0200
commit7ce5345e729a975bbaf6b8e03d0cf977eb367f8f (patch)
tree84abf45a4c60dcb5888cedde03f00029b3c69c38 /app-mobilephone/scrcpy/scrcpy-1.18.ebuild
parentsys-apps/ethtool: Removed old (diff)
downloadgentoo-7ce5345e729a975bbaf6b8e03d0cf977eb367f8f.tar.gz
gentoo-7ce5345e729a975bbaf6b8e03d0cf977eb367f8f.tar.bz2
gentoo-7ce5345e729a975bbaf6b8e03d0cf977eb367f8f.zip
app-mobilephone/scrcpy: initial import
Based on maggu2810 overlay ebuild Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-mobilephone/scrcpy/scrcpy-1.18.ebuild')
-rw-r--r--app-mobilephone/scrcpy/scrcpy-1.18.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-mobilephone/scrcpy/scrcpy-1.18.ebuild b/app-mobilephone/scrcpy/scrcpy-1.18.ebuild
new file mode 100644
index 000000000000..f446dc491375
--- /dev/null
+++ b/app-mobilephone/scrcpy/scrcpy-1.18.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Display and control your Android device"
+HOMEPAGE="https://github.com/Genymobile/scrcpy"
+# Source code and server part on Android device
+SRC_URI="https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/libsdl2[X]
+ media-video/ffmpeg"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ -Db_lto=true
+ -Dprebuilt_server="${DISTDIR}/${PN}-server-v${PV}"
+ )
+ meson_src_configure
+}