summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2019-08-25 19:16:45 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-13 13:40:22 +0200
commit23949ce99d48bdd95a22ad7905a3a8d4a6d4ab1c (patch)
tree50e843e6ad3fb9e5446b5a762b1561d26173cbae /app-office/gnucash
parentx11-libs/gdk-pixbuf: bump to 2.40.0 (diff)
downloadgentoo-23949ce99d48bdd95a22ad7905a3a8d4a6d4ab1c.tar.gz
gentoo-23949ce99d48bdd95a22ad7905a3a8d4a6d4ab1c.tar.bz2
gentoo-23949ce99d48bdd95a22ad7905a3a8d4a6d4ab1c.zip
app-office/gnucash: Don't build gtest from source
With gnucash-3.6, the build now looks for gtest headers and libraries and uses them if found. Closes: https://bugs.gentoo.org/691276 Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Peter Levine <plevine457@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12792 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/gnucash')
-rw-r--r--app-office/gnucash/gnucash-3.6.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/app-office/gnucash/gnucash-3.6.ebuild b/app-office/gnucash/gnucash-3.6.ebuild
index 9999712e8bfd..00c0d0fd915e 100644
--- a/app-office/gnucash/gnucash-3.6.ebuild
+++ b/app-office/gnucash/gnucash-3.6.ebuild
@@ -3,23 +3,20 @@
EAPI=6
-# google{test,mock} version
-GV="1.8.0"
PYTHON_COMPAT=( python3_{4,5,6} )
inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
DESCRIPTION="A personal finance manager"
HOMEPAGE="http://www.gnucash.org/"
-SRC_URI="https://github.com/Gnucash/${PN}/releases/download/${PV}/${P}.tar.bz2
- https://github.com/google/googletest/archive/release-${GV}.tar.gz -> gtest-${GV}.tar.gz"
+SRC_URI="https://github.com/Gnucash/${PN}/releases/download/${PV}/${P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="aqbanking chipcard debug doc examples gnome-keyring +gui mysql nls ofx
- postgres python quotes -register2 sqlite"
+ postgres python quotes -register2 sqlite test"
REQUIRED_USE="
chipcard? ( aqbanking )
@@ -70,12 +67,12 @@ RDEPEND="
"
DEPEND="${RDEPEND}
- ~dev-cpp/gtest-${GV}
>=sys-devel/gettext-0.19.6
dev-lang/perl
dev-perl/XML-Parser
sys-devel/libtool
virtual/pkgconfig
+ test? ( >=dev-cpp/gtest-1.8.0 )
"
PDEPEND="doc? (
@@ -104,8 +101,6 @@ src_configure() {
fi
local mycmakeargs=(
- -DGMOCK_ROOT="${WORKDIR}"/googletest-release-${GV}/googlemock
- -DGTEST_ROOT="${WORKDIR}"/googletest-release-${GV}/googletest
# Disable fallback to guile-2.0
-DCMAKE_DISABLE_FIND_PACKAGE_GUILE2=ON
-DCOMPILE_GSCHEMAS=OFF