summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-07 11:24:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-07 11:25:00 +0100
commite56cdacd4cf600ac4d2501aaf4fadcddb45b1b31 (patch)
treee5d2e29d9494c75648364c02f5750a75724cf0b4 /app-office/libreoffice-bin-debug
parentmedia-sound/rosegarden: dropped obsolete 23.06 (diff)
downloadgentoo-e56cdacd4cf600ac4d2501aaf4fadcddb45b1b31.tar.gz
gentoo-e56cdacd4cf600ac4d2501aaf4fadcddb45b1b31.tar.bz2
gentoo-e56cdacd4cf600ac4d2501aaf4fadcddb45b1b31.zip
app-office/libreoffice-bin-debug: Fix src_unpack phase (PVR -> PV)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/libreoffice-bin-debug')
-rw-r--r--app-office/libreoffice-bin-debug/libreoffice-bin-debug-7.5.6.2-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-office/libreoffice-bin-debug/libreoffice-bin-debug-7.5.6.2-r1.ebuild b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-7.5.6.2-r1.ebuild
index 5c1844501b9f..e66fb47d045e 100644
--- a/app-office/libreoffice-bin-debug/libreoffice-bin-debug-7.5.6.2-r1.ebuild
+++ b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-7.5.6.2-r1.ebuild
@@ -60,8 +60,8 @@ S="${WORKDIR}"
QA_PREBUILT="/usr/*"
src_unpack() {
- einfo "Uncompressing distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar.xz"
- xz -cd "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar.xz" > "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" || die
+ einfo "Uncompressing distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar.xz"
+ xz -cd "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar.xz" > "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar" || die
local patchname
use kde && patchname="-kde"
@@ -69,13 +69,13 @@ src_unpack() {
use java && patchname="${patchname}-java"
if [[ -n "${patchname}" ]]; then
- einfo "Patching distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar using ${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3"
- xdelta3 -d -s "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3" "${WORKDIR}/tmpdist.tar" || die
- mv "${WORKDIR}/tmpdist.tar" "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" || die
+ einfo "Patching distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar using ${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PV}.xd3"
+ xdelta3 -d -s "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar" "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PV}.xd3" "${WORKDIR}/tmpdist.tar" || die
+ mv "${WORKDIR}/tmpdist.tar" "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar" || die
fi
- einfo "Unpacking new ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar"
- unpack "./${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar"
+ einfo "Unpacking new ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar"
+ unpack "./${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PV}.tar"
}
src_configure() { :; }