summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-21 23:41:35 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-22 00:04:46 +0100
commitae16eca24fab4c388c4f1de8b463652419e91657 (patch)
tree2c07ba92494d3ca03957cb6b31cde6c7496c4504 /app-office
parentapp-containers/distrobox: bump to 1.8.1 (diff)
downloadgentoo-ae16eca24fab4c388c4f1de8b463652419e91657.tar.gz
gentoo-ae16eca24fab4c388c4f1de8b463652419e91657.tar.bz2
gentoo-ae16eca24fab4c388c4f1de8b463652419e91657.zip
app-office/joplin-desktop: bump to 3.2.11
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/joplin-desktop/Manifest1
-rw-r--r--app-office/joplin-desktop/joplin-desktop-3.2.11.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/app-office/joplin-desktop/Manifest b/app-office/joplin-desktop/Manifest
index 550684e6b475..12b74a5db3f9 100644
--- a/app-office/joplin-desktop/Manifest
+++ b/app-office/joplin-desktop/Manifest
@@ -1,4 +1,5 @@
DIST Joplin-3.1.24.AppImage 244603841 BLAKE2B 2175019cbcca58473fb9b7f6157f001ca3c36ede16cc62191c165c3852496dfabb811fc3507ab2e0c5981959e9be50bc8836d0108cc9c80969f6ce0f511f130a SHA512 e286186c07f64ca70f13a95584fa49b7c8ac97bb025c288ca5b15b8334f9ea52ed758cc272c3e6c277544785b02f24423f8af9191973245faef1974791a7366c
+DIST Joplin-3.2.11.AppImage 226032261 BLAKE2B 8c0907f19e884343511ee6fd4544e8174b8fe58276e4903f4033f25b2f96e435e53eb8aeebdac4c4e57ab1353dcfd9007095bf7f682c41815644ffc2d1035f61 SHA512 c818b0ad9540e3af6c7295c6b19dba18bb2dfb19fe69bb78d63f0f2318b5d1f95dde99e86e74f693afa4f1535fce04f769ca5870d4bc00e1854025e63bc36309
DIST Joplin-3.2.3.AppImage 386823720 BLAKE2B f75938fbe5a8a4de995966b5bbbd6bbb38a2581cf211b29e87a38587573ac49486957455a49a676c0a26a1c531bea48e09905caecd3c437bbda85cc0f1cd550a SHA512 b7019bf7a16edc4dbfbee9b9e76f0ef792267c044b4bd7c35aec1befdcb41b698640f5e2ba167883f4132da98db19b0c53c0e0757f4ce81683d0f410952fc43d
DIST Joplin-3.2.4.AppImage 282754638 BLAKE2B 612bbe8d3a972d63afc67a399ccd5cd8dd114e1338406203be8e9092340a794e7579ae318d0c7210584169328487b0674ed8bb6f0a3372459e93a25464f5ff31 SHA512 4e3273ccf10cfdc731e4c616bf72bd6827a48934938b2ad7dc2c7750cf66c2b0ed23b4bd4825b1fd561ca5115ec1bb5f13a1ecb54a90e260b48999b9e70e498d
DIST Joplin-3.2.7.AppImage 226047655 BLAKE2B 407aaddb916b5082b6c040dfa4510d03564612634eb236f2f58fe6217ec57319393073762633eb20988e48bd89eebb3233c068cb812e5e341229e2ee5520f08f SHA512 211aff435bb9d493087eb0906d50424d4a4ab740b4ef0a054a34949eb65a49adf45ba4efc1b738fd4d81fc0012d7c7ba1293b36ff3fd213ab64dc6b1323f34dc
diff --git a/app-office/joplin-desktop/joplin-desktop-3.2.11.ebuild b/app-office/joplin-desktop/joplin-desktop-3.2.11.ebuild
new file mode 100644
index 000000000000..e512dc366a9a
--- /dev/null
+++ b/app-office/joplin-desktop/joplin-desktop-3.2.11.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: This is a Electron app (oh my) and the upstream only provides AppImages.
+
+EAPI=8
+
+APPIMAGE="Joplin-${PV}.AppImage"
+
+inherit desktop xdg
+
+DESCRIPTION="Secure note taking and to-do app with synchronization capabilities"
+HOMEPAGE="https://joplinapp.org/
+ https://github.com/laurent22/joplin/"
+SRC_URI="https://github.com/laurent22/joplin/releases/download/v${PV}/${APPIMAGE}"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ || (
+ media-libs/libcanberra-gtk3
+ media-libs/libcanberra[gtk3(-)]
+ )
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ cp "${DISTDIR}/${APPIMAGE}" "${S}" || die
+
+ cd "${S}" || die # "appimage-extract" unpacks to current directory.
+ chmod +x "${S}/${APPIMAGE}" || die
+ "${S}/${APPIMAGE}" --appimage-extract || die
+}
+
+src_prepare() {
+ # Fix permissions.
+ find "${S}" -type d -exec chmod a+rx {} + || die
+ find "${S}" -type f -exec chmod a+r {} + || die
+
+ default
+}
+
+src_install() {
+ cd "${S}/squashfs-root" || die
+
+ insinto /usr/share
+ doins -r ./usr/share/icons
+
+ local apphome="/opt/${PN}"
+ local -a toremove=(
+ .DirIcon
+ AppRun
+ LICENSE.electron.txt
+ LICENSES.chromium.html
+ joplin.png
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm64
+ resources/app.asar.unpacked/node_modules/node-notifier
+ usr
+ )
+ rm -f -r "${toremove[@]}" || die
+
+ mkdir -p "${ED}/${apphome}" || die
+ cp -r . "${ED}/${apphome}" || die
+
+ dosym -r "${apphome}/joplin" "/usr/bin/${PN}"
+ make_desktop_entry "${PN}" Joplin joplin "Office;" \
+ "StartupWMClass=Joplin\nMimeType=x-scheme-handler/joplin;"
+}