summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-08 20:01:04 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-08 20:22:44 +0200
commitfe3d7bb1c895b97280a412c29216bd0ceea10a26 (patch)
treee1dd28c9ababd4f1361650757a767de4dc169369 /app-office
parentapp-misc/golly: call setup-wxwidgets in src_configure; bump python compat (diff)
downloadgentoo-fe3d7bb1c895b97280a412c29216bd0ceea10a26.tar.gz
gentoo-fe3d7bb1c895b97280a412c29216bd0ceea10a26.tar.bz2
gentoo-fe3d7bb1c895b97280a412c29216bd0ceea10a26.zip
app-office/joplin-desktop: bump to 3.0.13
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/joplin-desktop/Manifest1
-rw-r--r--app-office/joplin-desktop/joplin-desktop-3.0.13.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/app-office/joplin-desktop/Manifest b/app-office/joplin-desktop/Manifest
index e08cbc651c97..e0567ad826ca 100644
--- a/app-office/joplin-desktop/Manifest
+++ b/app-office/joplin-desktop/Manifest
@@ -1,2 +1,3 @@
DIST Joplin-3.0.12.AppImage 239283737 BLAKE2B 69c18d9cd77e0352a3c21e0225f9d6b866f5d1983a66700bb4a9fcd87c0c4476dbe292f0b1a7a3b8962c9dfef1d518501933a509772cd06661991e0edddb5fc3 SHA512 e53448e5cca06a33b16bef12df447b52b00287c0c73658523a261145efb8d3877dd662ff256a96d612b82390fed9431e8377baf16a0c28d1f6fc1062c2cde06a
+DIST Joplin-3.0.13.AppImage 239287815 BLAKE2B 0766d60d974698758872c046046b133629583f06cbc3b4fd33d0f4886bc7eba3188a47ec5205b5396dbe7a4bd537c0c9ec9677ace97a03dc0d0087c540bb1dd9 SHA512 f96ca6dfb18a5794236e16fd0c0e0c851af2cc20ecfd6095ebbdbf74bd29888726676744196927f84f5f03518ad2bb3960bb599c149b480b8a2383e936eb4a30
DIST Joplin-3.0.2.AppImage 253581812 BLAKE2B aa125e8bae0af2ff2e156378d221fd09dda43452b003da36486a59abb7323f81999242475450ab7e164712a060be4f59de68cfcf0736b5237db0e6f0b2914164 SHA512 da53055e23c8bf87e630bf2546c959b2b7a97d65193893c421793259055318ef5ba72f1ca897bcd60e76cc1f060db4f2bc4a39303640872301a7984dd4d7620a
diff --git a/app-office/joplin-desktop/joplin-desktop-3.0.13.ebuild b/app-office/joplin-desktop/joplin-desktop-3.0.13.ebuild
new file mode 100644
index 000000000000..a9c365263d83
--- /dev/null
+++ b/app-office/joplin-desktop/joplin-desktop-3.0.13.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: This is a Electron app (oh my) and the upstream only provides AppImages.
+
+EAPI=8
+
+APPIMAGE="Joplin-${PV}.AppImage"
+
+inherit desktop xdg
+
+DESCRIPTION="Secure note taking and to-do app with synchronization capabilities"
+HOMEPAGE="https://joplinapp.org/
+ https://github.com/laurent22/joplin/"
+SRC_URI="https://github.com/laurent22/joplin/releases/download/v${PV}/${APPIMAGE}"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libcanberra[gtk3]
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ cp "${DISTDIR}/${APPIMAGE}" "${S}" || die
+
+ cd "${S}" || die # "appimage-extract" unpacks to current directory.
+ chmod +x "${S}/${APPIMAGE}" || die
+ "${S}/${APPIMAGE}" --appimage-extract || die
+}
+
+src_prepare() {
+ # Fix permissions.
+ find "${S}" -type d -exec chmod a+rx {} + || die
+ find "${S}" -type f -exec chmod a+r {} + || die
+
+ default
+}
+
+src_install() {
+ cd "${S}/squashfs-root" || die
+
+ insinto /usr/share
+ doins -r ./usr/share/icons
+
+ local apphome="/opt/${PN}"
+ local toremove=(
+ .DirIcon
+ @joplinapp-desktop.desktop
+ @joplinapp-desktop.png
+ AppRun
+ LICENSE.electron.txt
+ LICENSES.chromium.html
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm64
+ resources/app.asar.unpacked/node_modules/node-notifier
+ usr
+ )
+ rm -f -r "${toremove[@]}" || die
+
+ mkdir -p "${ED}/${apphome}" || die
+ cp -r . "${ED}/${apphome}" || die
+
+ dosym -r "${apphome}/@joplinapp-desktop" "/usr/bin/${PN}"
+ make_desktop_entry "${PN}" Joplin @joplinapp-desktop "Office;" \
+ "StartupWMClass=Joplin\nMimeType=x-scheme-handler/joplin;"
+}