summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-01-03 18:44:26 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-01-03 18:53:47 +0100
commitb49e286c4a28bf9d9d6424861f24a3dc3b268062 (patch)
treede6484088bf8f091d16dfc56bd7b77b6fde4be82 /app-shells/rush/rush-2.2.ebuild
parentdev-python/ruamel-yaml: add 0.17.20 (diff)
downloadgentoo-b49e286c4a28bf9d9d6424861f24a3dc3b268062.tar.gz
gentoo-b49e286c4a28bf9d9d6424861f24a3dc3b268062.tar.bz2
gentoo-b49e286c4a28bf9d9d6424861f24a3dc3b268062.zip
app-shells/rush: Bump to version 2.2
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells/rush/rush-2.2.ebuild')
-rw-r--r--app-shells/rush/rush-2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/rush/rush-2.2.ebuild b/app-shells/rush/rush-2.2.ebuild
new file mode 100644
index 000000000000..66cb66e7a099
--- /dev/null
+++ b/app-shells/rush/rush-2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Restricted User Shell"
+HOMEPAGE="https://puszcza.gnu.org.ua/projects/rush/"
+SRC_URI="ftp://download.gnu.org.ua/pub/release/${PN}/${P}.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="nls"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+# Testsuite doesn't like our sandbox (bug #689554)
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}