summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-11-10 01:01:33 -0500
committerMike Frysinger <vapier@gentoo.org>2016-11-10 01:01:33 -0500
commit6a6d6915dfc68f4a67a7e8c03265d9e02ed39425 (patch)
tree0b93fd90899d76515d623eabbd639a37e32667e2 /app-shells
parentsys-libs/readline: add upstream patch for excessive history memory allocs #59... (diff)
downloadgentoo-6a6d6915dfc68f4a67a7e8c03265d9e02ed39425.tar.gz
gentoo-6a6d6915dfc68f4a67a7e8c03265d9e02ed39425.tar.bz2
gentoo-6a6d6915dfc68f4a67a7e8c03265d9e02ed39425.zip
app-shells/bash: drop unused memory patch #597006
The patch applies against the readline source which we delete in the bash ebuild, so it doesn't do anything useful here.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-4.4-r1.ebuild3
-rw-r--r--app-shells/bash/files/bash-4.4-history-alloclist.patch26
2 files changed, 0 insertions, 29 deletions
diff --git a/app-shells/bash/bash-4.4-r1.ebuild b/app-shells/bash/bash-4.4-r1.ebuild
index caed46fb36c2..41a650672f6c 100644
--- a/app-shells/bash/bash-4.4-r1.ebuild
+++ b/app-shells/bash/bash-4.4-r1.ebuild
@@ -74,9 +74,6 @@ src_prepare() {
# Include official patches
[[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- # bug 597006: large HISTFILESIZE value may result in upfront memory exhaustion
- epatch "${FILESDIR}"/${PN}-4.4-history-alloclist.patch
-
# Clean out local libs so we know we use system ones w/releases.
if [[ ${PV} != *_rc* ]] ; then
rm -rf lib/{readline,termcap}/*
diff --git a/app-shells/bash/files/bash-4.4-history-alloclist.patch b/app-shells/bash/files/bash-4.4-history-alloclist.patch
deleted file mode 100644
index 8072bde5e26f..000000000000
--- a/app-shells/bash/files/bash-4.4-history-alloclist.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-*** ../bash-4.4/lib/readline/history.c 2015-12-28 13:50:31.000000000 -0500
---- lib/readline/history.c 2016-09-30 14:28:40.000000000 -0400
-***************
-*** 58,61 ****
---- 58,63 ----
- #define DEFAULT_HISTORY_INITIAL_SIZE 502
-
-+ #define MAX_HISTORY_INITIAL_SIZE 8192
-+
- /* The number of slots to increase the_history by. */
- #define DEFAULT_HISTORY_GROW_SIZE 50
-***************
-*** 308,312 ****
- {
- if (history_stifled && history_max_entries > 0)
-! history_size = history_max_entries + 2;
- else
- history_size = DEFAULT_HISTORY_INITIAL_SIZE;
---- 310,316 ----
- {
- if (history_stifled && history_max_entries > 0)
-! history_size = (history_max_entries > MAX_HISTORY_INITIAL_SIZE)
-! ? MAX_HISTORY_INITIAL_SIZE
-! : history_max_entries + 2;
- else
- history_size = DEFAULT_HISTORY_INITIAL_SIZE;