summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-09-06 09:21:04 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-06 12:11:44 +0200
commit0663c0bec3c1bda2daadc9c1d2b9b6506a148b8b (patch)
tree1aa612b63e20ff668c3519ffd14944ec2a2f30b7 /app-text/asciidoc
parentmedia-libs/plotutils: update LICENSE (diff)
downloadgentoo-0663c0bec3c1bda2daadc9c1d2b9b6506a148b8b.tar.gz
gentoo-0663c0bec3c1bda2daadc9c1d2b9b6506a148b8b.tar.bz2
gentoo-0663c0bec3c1bda2daadc9c1d2b9b6506a148b8b.zip
app-text/asciidoc: add 10.2.1
Closes: https://bugs.gentoo.org/834835 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/Manifest1
-rw-r--r--app-text/asciidoc/asciidoc-10.2.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index ba6c37529be0..72b8571bf87e 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1,2 +1,3 @@
DIST asciidoc-10.2.0.tar.gz 216824 BLAKE2B 500038d655f820fe89048bbff683ae029c7044de839ae4f9ec4666b843585511c99bbc1991ec1764262f33c55b08845661fc1e62eb21bb3250d3168e369928ff SHA512 2f83c7f6d1d0a34948035347833ca59841de1271e8d008b4c4a43a7a8273b230148e6f51ee8f6e2dc702460e27c495037fbe2d6d43195b70bf3447ad86390d28
+DIST asciidoc-10.2.1.tar.gz 1280535 BLAKE2B 9e15eb5d40384fe586a6148e53e03e73a6958061841843f7b32b4209a15477f97a6547ea1cb48d23b5d4c9ee5add1bfa87d53c1bfbc14c10f31397ebeb86ba39 SHA512 02d064aab8dfb05af4ae49a7c7bd1381156c6c90f95b2494218c80f01c39987cb971d68c533b5519abade77be9832b3fab653d8ae2ca7bb682c5bb720612839f
DIST asciidoc-9.1.0.new.tar.gz 1249958 BLAKE2B 0a98f58f7604f84d704092313c38563634bad5d697d60d02760f3be1d2a78a97ee2488dda3a9918b02e0062710175c6513d600f3fbd850fe700bf3fa917a3980 SHA512 c30854a936228fe5bcf2f9305741fbc4b17ef088b2fa637d5f3b19c7803306085634fb71146f0b089c2fad01f986da71a4fae364139f520c0906525317c0c4a6
diff --git a/app-text/asciidoc/asciidoc-10.2.1.ebuild b/app-text/asciidoc/asciidoc-10.2.1.ebuild
new file mode 100644
index 000000000000..f72e23de4920
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-10.2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+inherit distutils-r1 optfeature readme.gentoo-r1
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="
+ https://asciidoc.org/
+ https://github.com/asciidoc-py/asciidoc-py/
+"
+SRC_URI="https://github.com/asciidoc-py/asciidoc-py/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2
+"
+BDEPEND="
+ test? ( $(python_gen_cond_dep '
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ ') )
+"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ # TODO: Consider using Debian patch to allow /usr/share?
+ insinto /usr/share/asciidoc
+ doins -r asciidoc/resources/.
+
+ doman doc/*.1 # bug 834835
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "music filter support" \
+ "media-sound/lilypond virtual/imagemagick-tools"
+ optfeature "source filter support" \
+ "dev-util/source-highlight dev-python/pygments app-text/highlight"
+ optfeature "latex filter support" \
+ "dev-texlive/texlive-latex app-text/dvipng" \
+ "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "graphviz filter support" "media-gfx/graphviz"
+}