summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-02-25 16:30:57 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-02-25 16:42:03 -0600
commit000faa37b1b4704842c98552340cac5dcfa23a3c (patch)
tree6be2f6010a89f7fceeab4eb4bac3b0be0a6341bf /app-text/barcode/barcode-0.99.ebuild
parentdev-vcs/vcsh: version bump to 1.20151229.1 (diff)
downloadgentoo-000faa37b1b4704842c98552340cac5dcfa23a3c.tar.gz
gentoo-000faa37b1b4704842c98552340cac5dcfa23a3c.tar.bz2
gentoo-000faa37b1b4704842c98552340cac5dcfa23a3c.zip
app-text/barcode: version bump to 0.99
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/barcode/barcode-0.99.ebuild')
-rw-r--r--app-text/barcode/barcode-0.99.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/barcode/barcode-0.99.ebuild b/app-text/barcode/barcode-0.99.ebuild
new file mode 100644
index 000000000000..e2edb1fea451
--- /dev/null
+++ b/app-text/barcode/barcode-0.99.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils multilib
+
+DESCRIPTION="barcode generator"
+HOMEPAGE="https://www.gnu.org/software/barcode/"
+SRC_URI="mirror://gnu/barcode/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+RDEPEND="app-text/libpaper"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/^LDFLAGS =/s:=:+=:' \
+ -e "/^aLIBDIR/s:lib:$(get_libdir):" \
+ -e '/^INFODIR/s:info:share/info:' \
+ -e '/^MAN/s:man:share/man:' \
+ Makefile.in || die
+
+ default
+}
+
+src_install() {
+ default
+ dodoc ChangeLog README TODO
+}