summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/cmigemo/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/cmigemo/files')
-rw-r--r--app-text/cmigemo/files/cmigemo-1.2-migemo-dict.diff23
-rw-r--r--app-text/cmigemo/files/cmigemo-1.3c-gentoo.patch55
-rw-r--r--app-text/cmigemo/files/cmigemo-1.3c-ldflags.patch13
3 files changed, 91 insertions, 0 deletions
diff --git a/app-text/cmigemo/files/cmigemo-1.2-migemo-dict.diff b/app-text/cmigemo/files/cmigemo-1.2-migemo-dict.diff
new file mode 100644
index 000000000000..a216ceafb0ca
--- /dev/null
+++ b/app-text/cmigemo/files/cmigemo-1.2-migemo-dict.diff
@@ -0,0 +1,23 @@
+diff -urN cmigemo-1.2.ORIG/tools/migemo.vim cmigemo-1.2/tools/migemo.vim
+--- cmigemo-1.2.ORIG/tools/migemo.vim 2003-01-07 22:57:59.000000000 +0900
++++ cmigemo-1.2/tools/migemo.vim 2004-03-13 17:25:31.944190968 +0900
+@@ -20,7 +20,7 @@
+ let dict = globpath(path, "migemo-dict")
+ endif
+ if dict == ''
+- let dict = '/usr/local/share/migemo/'.&encoding.'/migemo-dict'
++ let dict = '/usr/share/migemo/migemo-dict'
+ if !filereadable(dict)
+ let dict = ''
+ endif
+@@ -43,7 +43,9 @@
+ nnoremap <Leader>f :call <SID>SearchChar(0)<CR>
+ else
+ " non-builtin version
+- let g:migemodict = s:SearchDict()
++ if !exists('g:migemodict')
++ let g:migemodict = s:SearchDict()
++ endif
+ command! -nargs=* Migemo :call <SID>MigemoSearch(<q-args>)
+ nnoremap <silent> <leader>mi :call <SID>MigemoSearch('')<cr>
+
diff --git a/app-text/cmigemo/files/cmigemo-1.3c-gentoo.patch b/app-text/cmigemo/files/cmigemo-1.3c-gentoo.patch
new file mode 100644
index 000000000000..2f903bb9bb62
--- /dev/null
+++ b/app-text/cmigemo/files/cmigemo-1.3c-gentoo.patch
@@ -0,0 +1,55 @@
+diff -Naur cmigemo-1.3c-MIT.orig/compile/Make_gcc.mak cmigemo-1.3c-MIT/compile/Make_gcc.mak
+--- cmigemo-1.3c-MIT.orig/compile/Make_gcc.mak 2003-10-19 16:00:59.000000000 +0900
++++ cmigemo-1.3c-MIT/compile/Make_gcc.mak 2009-11-08 16:45:32.485952233 +0900
+@@ -14,7 +14,7 @@
+ libmigemo = libmigemo.so
+ EXEEXT =
+ CFLAGS_MIGEMO = -fPIC
+-LDFLAGS_MIGEMO = -Wl,-rpath,.,-rpath,/usr/local/lib,-rpath,/usr/lib
++LDFLAGS_MIGEMO =
+
+ include config.mk
+ include compile/unix.mak
+diff -Naur cmigemo-1.3c-MIT.orig/configure cmigemo-1.3c-MIT/configure
+--- cmigemo-1.3c-MIT.orig/configure 2004-06-19 12:50:27.000000000 +0900
++++ cmigemo-1.3c-MIT/configure 2009-11-08 16:40:42.688962262 +0900
+@@ -31,12 +31,12 @@
+ fi
+
+ # Check encoding filter
+-if CHECK_COMMAND qkc ; then
+- PROGRAM_ENCODEFILTER="qkc -q -u"
+-elif CHECK_COMMAND nkf ; then
++if CHECK_COMMAND nkf ; then
+ PROGRAM_ENCODEFILTER="nkf -x"
++elif CHECK_COMMAND qkc ; then
++ PROGRAM_ENCODEFILTER="qkc -q -u"
+ else
+- echo "ERROR: Require qkc or nkf installed for encode filter."
++ echo "ERROR: Require nkf or qkc installed for encode filter."
+ exit 1
+ fi
+
+diff -Naur cmigemo-1.3c-MIT.orig/tools/migemo.vim cmigemo-1.3c-MIT/tools/migemo.vim
+--- cmigemo-1.3c-MIT.orig/tools/migemo.vim 2004-02-23 16:32:53.000000000 +0900
++++ cmigemo-1.3c-MIT/tools/migemo.vim 2009-11-08 16:42:19.572951008 +0900
+@@ -20,7 +20,7 @@
+ let dict = globpath(path, "migemo-dict")
+ endif
+ if dict == ''
+- let dict = '/usr/local/share/migemo/'.&encoding.'/migemo-dict'
++ let dict = '/usr/share/migemo/migemo-dict'
+ if !filereadable(dict)
+ let dict = ''
+ endif
+@@ -43,7 +43,9 @@
+ nnoremap <Leader>f :call <SID>SearchChar(0)<CR>
+ else
+ " non-builtin version
+- let g:migemodict = s:SearchDict()
++ if !exists('g:migemodict')
++ let g:migemodict = s:SearchDict()
++ endif
+ command! -nargs=* Migemo :call <SID>MigemoSearch(<q-args>)
+ nnoremap <silent> <leader>mi :call <SID>MigemoSearch('')<cr>
+
diff --git a/app-text/cmigemo/files/cmigemo-1.3c-ldflags.patch b/app-text/cmigemo/files/cmigemo-1.3c-ldflags.patch
new file mode 100644
index 000000000000..2f4f8c922431
--- /dev/null
+++ b/app-text/cmigemo/files/cmigemo-1.3c-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/compile/Make_gcc.mak b/compile/Make_gcc.mak
+index f042ac6..f91fe92 100644
+--- a/compile/Make_gcc.mak
++++ b/compile/Make_gcc.mak
+@@ -28,7 +28,7 @@ include compile/clean_unix.mak
+ #
+ $(libmigemo_LIB): $(libmigemo_DSO)
+ $(libmigemo_DSO): $(libmigemo_OBJ)
+- $(CC) -shared -o $(libmigemo_LIB) -Wl,-soname,$@ $(libmigemo_OBJ)
++ $(CC) -shared -o $(libmigemo_LIB) -Wl,-soname,$@ $(libmigemo_OBJ) $(LDFLAGS)
+ $(RM) $@ $(libmigemo)
+ ln -s $(libmigemo_LIB) $@
+ ln -s $(libmigemo_LIB) $(libmigemo)